summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-25 05:36:26 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-25 05:36:26 +0000
commit318fc84821e91e3279dfe7797d8bf329f5cbb362 (patch)
tree99b6565e92c351c1614359d21845c40c2adf923b /dev-ruby/rjb/rjb-1.4.9.ebuild
parentVersion bump. (diff)
downloadhistorical-318fc84821e91e3279dfe7797d8bf329f5cbb362.tar.gz
historical-318fc84821e91e3279dfe7797d8bf329f5cbb362.tar.bz2
historical-318fc84821e91e3279dfe7797d8bf329f5cbb362.zip
Version bump. Install documentation. Fix tests to work and avoid tests that cannot work for us. Use eclass to install additional files. Add ruby20, ruby21.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x8883FA56A308A8D7!
Diffstat (limited to 'dev-ruby/rjb/rjb-1.4.9.ebuild')
-rw-r--r--dev-ruby/rjb/rjb-1.4.9.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/rjb/rjb-1.4.9.ebuild b/dev-ruby/rjb/rjb-1.4.9.ebuild
new file mode 100644
index 000000000000..1c1b8fb8d49a
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.4.9.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.4.9.ebuild,v 1.1 2014/04/25 05:36:25 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="http://rjb.rubyforge.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+all_ruby_prepare() {
+ # The console is not available for testing.
+ sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die
+
+ # Avoid encoding tests since not all locales may be available.
+ sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb may only work if ruby is MPROTECT disabled, but not really sure\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+}