summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-05 08:59:13 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-05 08:59:13 +0000
commit864e0b197e1d83ff409d5bc767e6f4bc5565b5bd (patch)
tree74e902ea6697072fe5eb4aff7ba44e07b62878f4 /dev-ruby
parentInitial import for Rails 3. Split off from dev-ruby/rails. (diff)
downloadhistorical-864e0b197e1d83ff409d5bc767e6f4bc5565b5bd.tar.gz
historical-864e0b197e1d83ff409d5bc767e6f4bc5565b5bd.tar.bz2
historical-864e0b197e1d83ff409d5bc767e6f4bc5565b5bd.zip
Version bump for Rails 3.
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.3.ebuild35
-rw-r--r--dev-ruby/actionpack/ChangeLog7
-rw-r--r--dev-ruby/actionpack/actionpack-3.0.3.ebuild51
4 files changed, 99 insertions, 2 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index e8b799a08e7e..ef18a8735568 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.147 2010/10/15 08:01:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.148 2010/12/05 08:59:13 graaff Exp $
+
+*actionmailer-3.0.3 (05 Dec 2010)
+
+ 05 Dec 2010; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-3.0.3.ebuild:
+ Version bump for Rails 3.
15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
-actionmailer-2.3.9.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild
new file mode 100644
index 000000000000..877454dd6157
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.3.ebuild,v 1.1 2010/12/05 08:59:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.9"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index f3d1d9ebc624..bd8759e27cee 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.161 2010/10/15 08:02:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.162 2010/12/05 08:54:40 graaff Exp $
+
+*actionpack-3.0.3 (05 Dec 2010)
+
+ 05 Dec 2010; Hans de Graaff <graaff@gentoo.org> +actionpack-3.0.3.ebuild:
+ Version bump for Rails 3.
15 Oct 2010; Hans de Graaff <graaff@gentoo.org> -actionpack-2.3.9.ebuild:
Remove vulnerable version.
diff --git a/dev-ruby/actionpack/actionpack-3.0.3.ebuild b/dev-ruby/actionpack/actionpack-3.0.3.ebuild
new file mode 100644
index 000000000000..9ba684d6faaf
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-3.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-3.0.3.ebuild,v 1.1 2010/12/05 08:54:40 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# The default test task tries to test activerecord with SQLite as well.
+#RUBY_FAKEGEM_TASK_TEST="test_action_pack"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S="${WORKDIR}/rails-rails-*/actionpack"
+
+ruby_add_rdepend "
+ ~dev-ruby/activemodel-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/erubis-2.6.6
+ >=dev-ruby/i18n-0.4.1:0.4
+ >=dev-ruby/rack-1.2.1
+ >=dev-ruby/rack-mount-0.6.12
+ >=dev-ruby/rack-test-0.5.4
+ >=dev-ruby/tzinfo-0.3.23"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/activerecord:${SLOT}
+ dev-ruby/actionmailer:${SLOT}
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}