summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 12:51:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 12:51:16 +0000
commit7842cb09d694589c511f2b21ce3584951b8a8807 (patch)
tree49b7fc4b229b4602d6bb3d8188763d595e307d9e /dev-tcltk
parentRespecting multilib and LDFLAGS, #290090 & #341883 (diff)
downloadhistorical-7842cb09d694589c511f2b21ce3584951b8a8807.tar.gz
historical-7842cb09d694589c511f2b21ce3584951b8a8807.tar.bz2
historical-7842cb09d694589c511f2b21ce3584951b8a8807.zip
Respecting multilib and LDFLAGS, #290090 & #341883
Package-Manager: portage-2.2.0_alpha7/cvs/Linux x86_64
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tcldom/ChangeLog8
-rw-r--r--dev-tcltk/tcldom/files/3.1-ldflags.patch13
-rw-r--r--dev-tcltk/tcldom/tcldom-2.6.ebuild33
-rw-r--r--dev-tcltk/tcldom/tcldom-3.0.ebuild64
-rw-r--r--dev-tcltk/tcldom/tcldom-3.1.ebuild25
5 files changed, 35 insertions, 108 deletions
diff --git a/dev-tcltk/tcldom/ChangeLog b/dev-tcltk/tcldom/ChangeLog
index 3174c6b53497..3bae14acd1c5 100644
--- a/dev-tcltk/tcldom/ChangeLog
+++ b/dev-tcltk/tcldom/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-tcltk/tcldom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.13 2010/12/07 12:49:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/ChangeLog,v 1.14 2010/12/07 12:51:11 jlec Exp $
07 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/3.1-ldflags.patch,
- -tcldom-2.6.ebuild, tcldom-3.1.ebuild:
+ -tcldom-3.0.ebuild:
+ Respecting multilib and LDFLAGS, #290090 & #341883
+
+ 07 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/3.1-ldflags.patch,
+ -tcldom-3.0.ebuild:
Respecting multilib and LDFLAGS, #290090 & #341883
20 Oct 2010; Christian Faulhammer <fauli@gentoo.org> tcldom-3.1.ebuild:
diff --git a/dev-tcltk/tcldom/files/3.1-ldflags.patch b/dev-tcltk/tcldom/files/3.1-ldflags.patch
new file mode 100644
index 000000000000..5a7714cd7ab5
--- /dev/null
+++ b/dev-tcltk/tcldom/files/3.1-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 8f273eb..d005731 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -95,7 +95,7 @@ package: $(tcldom_LIB_FILE)
+
+ $(tcldom_LIB_FILE): $(tcldom_OBJECTS)
+ -rm -f $(tcldom_LIB_FILE)
+- $(SHLIB_LD) $(SHLIB_LDFLAGS) @SHLIB_LD_OUT@$@ \
++ $(SHLIB_LD) $(SHLIB_LDFLAGS) $(LDFLAGS) @SHLIB_LD_OUT@$@ \
+ $(tcldom_OBJECTS) $(tcldom_LIBRARIES) $(SHLIB_LD_LIBS)
+
+ ## Documentation section.
diff --git a/dev-tcltk/tcldom/tcldom-2.6.ebuild b/dev-tcltk/tcldom/tcldom-2.6.ebuild
deleted file mode 100644
index 905527ee9488..000000000000
--- a/dev-tcltk/tcldom/tcldom-2.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-2.6.ebuild,v 1.6 2006/06/04 02:34:19 matsuu Exp $
-
-DESCRIPTION="Document Object Model For Tcl"
-HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
-SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
-
-DEPEND=">=dev-lang/tcl-8.3.3"
-RDEPEND="${DEPEND}
- >=dev-tcltk/tclxml-2.6"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # bug 131148
- sed -i -e "s/relid'/relid/" \
- {,src-libxml2/}configure {config,tclconfig}/tcl.m4 || die
-}
-
-src_compile() {
- econf || die
- make || die
-}
-
-src_install() {
- einstall || die
- dodoc ChangeLog LICENSE README RELNOTES
-}
diff --git a/dev-tcltk/tcldom/tcldom-3.0.ebuild b/dev-tcltk/tcldom/tcldom-3.0.ebuild
deleted file mode 100644
index 86e723beefb8..000000000000
--- a/dev-tcltk/tcldom/tcldom-3.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.0.ebuild,v 1.3 2006/06/03 19:56:32 matsuu Exp $
-
-inherit eutils
-
-DESCRIPTION="Document Object Model For Tcl"
-HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
-SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
-
-IUSE="expat xml threads"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-
-DEPEND=">=dev-lang/tcl-8.3.3
- >=dev-tcltk/tcllib-1.2
- ~dev-tcltk/tclxml-3.0
- expat? ( dev-libs/expat )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}/library
- sed -e "s/@VERSION@/${PV}/" \
- -e "s/@Tcldom_LIB_FILE@@/UNSPECIFIED/" \
- < pkgIndex.tcl.in > pkgIndex.tcl
-}
-
-src_compile() {
- local myconf=""
-
- use threads && myconf="${myconf} --enable-threads"
-
- if use xml ; then
- cd ${S}/src-libxml2
- econf ${myconf} || die
- emake || die
- fi
- if use expat ; then
- cd ${S}/src
- econf ${myconf} || die
- emake || die
- fi
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}${PV}
- doins library/*.tcl || die
-
- if use xml ; then
- cd ${S}/src-libxml2
- make DESTDIR=${D} install || die
- fi
- if use expat ; then
- cd ${S}/src
- make DESTDIR=${D} install || die
- fi
-
- cd ${S}
- dodoc ChangeLog LICENSE README RELNOTES
- docinto examples; dodoc examples/*
- dohtml docs/*.html
-}
diff --git a/dev-tcltk/tcldom/tcldom-3.1.ebuild b/dev-tcltk/tcldom/tcldom-3.1.ebuild
index 3c3e236421e3..9d34684a673a 100644
--- a/dev-tcltk/tcldom/tcldom-3.1.ebuild
+++ b/dev-tcltk/tcldom/tcldom-3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.1.ebuild,v 1.3 2010/10/20 09:58:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcldom/tcldom-3.1.ebuild,v 1.4 2010/12/07 12:49:41 jlec Exp $
-inherit eutils
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Document Object Model For Tcl"
HOMEPAGE="http://tclxml.sourceforge.net/tcldom.html"
@@ -17,10 +17,15 @@ DEPEND=">=dev-lang/tcl-8.3.3
>=dev-tcltk/tcllib-1.2
~dev-tcltk/tclxml-3.1
expat? ( dev-libs/expat )"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+
cd "${S}/library"
sed -e "s/@VERSION@/${PV}/" \
-e "s/@Tcldom_LIB_FILE@@/UNSPECIFIED/" \
@@ -31,19 +36,21 @@ src_unpack() {
}
src_compile() {
- local myconf=""
+ local myconf="--with-tcl=/usr/$(get_libdir)"
+
+ tc-export CC
use threads && myconf="${myconf} --enable-threads"
if use xml ; then
cd "${S}/src-libxml2"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
fi
if use expat ; then
cd "${S}/src"
- econf ${myconf} || die
- emake || die
+ LDFLAGS="${LDFLAGS}" econf ${myconf}
+ emake LDFLAGS_OPTIMIZE="${LDFLAGS}" || die
fi
}
@@ -61,7 +68,7 @@ src_install() {
fi
cd "${S}"
- dodoc ChangeLog LICENSE README RELNOTES
- docinto examples; dodoc examples/*
- dohtml docs/*.html
+ dodoc ChangeLog README RELNOTES || die
+ docinto examples; dodoc examples/* || die
+ dohtml docs/*.html || die
}