summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Walls <malverian@gentoo.org>2005-08-18 16:15:50 +0000
committerPhilip Walls <malverian@gentoo.org>2005-08-18 16:15:50 +0000
commit2c7f9a36af4892e8135c1d6a07dfef78817404a5 (patch)
tree4a2425ed29300d4e2725790b0db511370b8333ea /dev-util/anjuta/anjuta-1.2.4.ebuild
parentamd64 fix (diff)
downloadhistorical-2c7f9a36af4892e8135c1d6a07dfef78817404a5.tar.gz
historical-2c7f9a36af4892e8135c1d6a07dfef78817404a5.tar.bz2
historical-2c7f9a36af4892e8135c1d6a07dfef78817404a5.zip
version bump, fix pango issue/amd64 problems
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-util/anjuta/anjuta-1.2.4.ebuild')
-rw-r--r--dev-util/anjuta/anjuta-1.2.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/anjuta/anjuta-1.2.4.ebuild b/dev-util/anjuta/anjuta-1.2.4.ebuild
new file mode 100644
index 000000000000..31c35e8ce6f4
--- /dev/null
+++ b/dev-util/anjuta/anjuta-1.2.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-1.2.4.ebuild,v 1.1 2005/08/18 16:15:50 malverian Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A versatile IDE for GNOME"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://anjuta.sourceforge.net/"
+
+IUSE="doc"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc amd64"
+
+RDEPEND=">=dev-libs/glib-2.0.6
+ >=x11-libs/gtk+-2.0.8
+ >=gnome-base/orbit-2.10.3
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2.0.2
+ >=gnome-base/libgnomeui-2.0.2
+ >=gnome-base/libgnomeprint-2.0.1
+ >=gnome-base/libgnomeprintui-2.0.1
+ >=gnome-base/gnome-vfs-2.0.2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2.0.1
+ >=x11-libs/vte-0.9
+ >=dev-libs/libxml2-2.4.23
+ >=x11-libs/pango-1.1.1
+ dev-libs/libpcre
+ app-text/scrollkeeper"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS COPYING ChangeLog FUTURE NEWS README THANKS TODO "
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_postinst() {
+
+ gnome2_pkg_postinst
+
+ if use doc; then
+ dodoc ${S}/manuals
+ dodoc ${S}/doc
+ fi
+
+ einfo
+ einfo "Some project templates may require additional development"
+ einfo "libraries to function correctly. It goes beyond the scope"
+ einfo "of this ebuild to provide them."
+ einfo
+
+ ewarn "If code autocompletion is missing gtk+ and other pkg-config"
+ ewarn "managed package headers, resolve any errors produced by the"
+ ewarn "following command, and then re-emerge anjuta:"
+ ewarn
+ ewarn "# pkg-config --cflags \`pkg-config --list-all 2>/dev/null | awk '{printf(\"%s \",\$1);}'\`"
+ ewarn
+}