summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-20 19:58:09 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-20 19:58:09 +0000
commit535f3563254af7e16288af6ceca261462d98dbfe (patch)
treea85c488de56e9444573f8081b88e764b618ddc72 /dev-util/gob/gob-2.0.2.ebuild
parentUpdated ebuild based on suggestions by Eric Renfro. Please report any (diff)
downloadhistorical-535f3563254af7e16288af6ceca261462d98dbfe.tar.gz
historical-535f3563254af7e16288af6ceca261462d98dbfe.tar.bz2
historical-535f3563254af7e16288af6ceca261462d98dbfe.zip
New version
Diffstat (limited to 'dev-util/gob/gob-2.0.2.ebuild')
-rw-r--r--dev-util/gob/gob-2.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/gob/gob-2.0.2.ebuild b/dev-util/gob/gob-2.0.2.ebuild
new file mode 100644
index 000000000000..63c8839289b0
--- /dev/null
+++ b/dev-util/gob/gob-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gob/gob-2.0.2.ebuild,v 1.1 2002/08/20 19:58:09 stroke Exp $
+
+MY_P=${PN}2-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GOB is a preprocessor for making GTK+ objects with inline C code"
+SRC_URI="http://ftp.5z.com/pub/gob/${MY_P}.tar.gz"
+HOMEPAGE="http://www.5z.com/jirka/gob.html"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+RDEPEND="=dev-libs/glib-2.0*
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_compile() {
+ econf || die "configure fail"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING COPYING.generated-code ChangeLog NEWS README TODO
+}