summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-05-14 18:02:34 +0000
committerMichael Januszewski <spock@gentoo.org>2004-05-14 18:02:34 +0000
commitdea2bce4d00374e114cf566b054423235e0b4208 (patch)
tree9b7f44a56758ae3edac9f52b298df84a5eca99e4 /dev-util/oprofile
parentNew release: 1.6.4 (diff)
downloadhistorical-dea2bce4d00374e114cf566b054423235e0b4208.tar.gz
historical-dea2bce4d00374e114cf566b054423235e0b4208.tar.bz2
historical-dea2bce4d00374e114cf566b054423235e0b4208.zip
Version bump.
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog7
-rw-r--r--dev-util/oprofile/Manifest4
-rw-r--r--dev-util/oprofile/files/digest-oprofile-0.81
-rw-r--r--dev-util/oprofile/oprofile-0.8.ebuild72
4 files changed, 82 insertions, 2 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 7346112054af..988996279cf5 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.4 2004/04/13 10:05:30 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.5 2004/05/14 18:02:34 spock Exp $
+
+*oprofile-0.8 (14 May 2004)
+
+ 14 May 2004; Michal Januszewski <spock@gentoo.org> +oprofile-0.8.ebuild:
+ Version bump.
13 Apr 2004; Michal Januszewski <spock@gentoo.org> oprofile-0.7.1.ebuild,
oprofile-0.7.ebuild:
diff --git a/dev-util/oprofile/Manifest b/dev-util/oprofile/Manifest
index d35cda88f87d..d85f2a744cc6 100644
--- a/dev-util/oprofile/Manifest
+++ b/dev-util/oprofile/Manifest
@@ -1,6 +1,8 @@
MD5 8cf3c9519ce31c509d0da8ab48828c77 oprofile-0.7.ebuild 1654
MD5 0e0c2d95af89498863e29062f84556c2 oprofile-0.7.1.ebuild 1930
-MD5 36cbb8ca3a9fe13d571810c075b98cb8 ChangeLog 827
+MD5 98607264073526901ec340a002d128c8 ChangeLog 948
+MD5 89fed2af553d6885263d954a1f367262 oprofile-0.8.ebuild 1870
MD5 3d4a085e59f4ef22017d52452649205b metadata.xml 310
MD5 8fb81a645cd9dcca67423b0e42d7255c files/digest-oprofile-0.7.1 66
MD5 06028442781220898a045871c9db7de6 files/digest-oprofile-0.7 64
+MD5 c90612912e77016c9aa69bb752907940 files/digest-oprofile-0.8 64
diff --git a/dev-util/oprofile/files/digest-oprofile-0.8 b/dev-util/oprofile/files/digest-oprofile-0.8
new file mode 100644
index 000000000000..693f12a91c09
--- /dev/null
+++ b/dev-util/oprofile/files/digest-oprofile-0.8
@@ -0,0 +1 @@
+MD5 8f5123f7646edbdbe24f0cb6c86114ee oprofile-0.8.tar.gz 592430
diff --git a/dev-util/oprofile/oprofile-0.8.ebuild b/dev-util/oprofile/oprofile-0.8.ebuild
new file mode 100644
index 000000000000..10b7b21a140e
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.8.ebuild,v 1.1 2004/05/14 18:02:34 spock Exp $
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( >=x11-libs/qt-3.2.1-r2 )"
+
+src_compile() {
+ check_KV
+
+ local myconf=""
+
+ if [ `use qt` ]
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}