summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-02-26 01:47:58 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-02-26 01:47:58 +0000
commita13f5595c277e60e39ce8a17184fab69e9ceb2ee (patch)
tree625c4d949ce8960105f564b83e3a0489fd400aa9 /dev-util/scons
parentUpdating to -r2 to solve bug 42335 (diff)
downloadhistorical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.tar.gz
historical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.tar.bz2
historical-a13f5595c277e60e39ce8a17184fab69e9ceb2ee.zip
Byte-compile .py files, closing bug #42660.
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/ChangeLog9
-rw-r--r--dev-util/scons/Manifest8
-rw-r--r--dev-util/scons/files/digest-scons-0.94-r21
-rw-r--r--dev-util/scons/scons-0.94-r2.ebuild31
4 files changed, 44 insertions, 5 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 0f5e46e23461..6e07fca7b518 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/scons
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.11 2003/12/16 20:35:36 lanius Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.12 2004/02/26 01:47:57 kloeri Exp $
+
+*scons-0.94-r2 (26 Feb 2004)
+
+ 26 Feb 2004; <kloeri@gentoo.org> scons-0.94-r2.ebuild:
+ Byte-compile .py files, closing bug #42660.
*scons-0.94-r1 (16 Dec 2003)
diff --git a/dev-util/scons/Manifest b/dev-util/scons/Manifest
index 2d79e154e1fb..b6cb32fe7561 100644
--- a/dev-util/scons/Manifest
+++ b/dev-util/scons/Manifest
@@ -1,5 +1,7 @@
-MD5 306e893a69bf540af9ffb9b3d0cfd8c8 scons-0.94-r1.ebuild 630
+MD5 3e01891fa067a162bb255e848f2e3b0b ChangeLog 2005
MD5 77c34dfc8bf18ab1339c8f0b3fde9a49 scons-0.0.9.ebuild 622
-MD5 d4ac42457d7344226659cd1afdfcd92a ChangeLog 1871
-MD5 4dc4ffb0858a0519ac3df0210d3a9324 files/digest-scons-0.94-r1 62
+MD5 306e893a69bf540af9ffb9b3d0cfd8c8 scons-0.94-r1.ebuild 630
+MD5 75ec326f8e46436765ac9f20bd53bdb2 scons-0.94-r2.ebuild 737
MD5 1e281c5c3a071165dab94961bab8d741 files/digest-scons-0.0.9 62
+MD5 4dc4ffb0858a0519ac3df0210d3a9324 files/digest-scons-0.94-r2 62
+MD5 4dc4ffb0858a0519ac3df0210d3a9324 files/digest-scons-0.94-r1 62
diff --git a/dev-util/scons/files/digest-scons-0.94-r2 b/dev-util/scons/files/digest-scons-0.94-r2
new file mode 100644
index 000000000000..497ab0b4f323
--- /dev/null
+++ b/dev-util/scons/files/digest-scons-0.94-r2
@@ -0,0 +1 @@
+MD5 b51a12f21b2fc8ba20dcb98aa53a8e6e scons-0.94.tar.gz 237154
diff --git a/dev-util/scons/scons-0.94-r2.ebuild b/dev-util/scons/scons-0.94-r2.ebuild
new file mode 100644
index 000000000000..c9a703ec9034
--- /dev/null
+++ b/dev-util/scons/scons-0.94-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.94-r2.ebuild,v 1.1 2004/02/26 01:47:58 kloeri Exp $
+
+inherit python distutils
+
+DESCRIPTION="Extensible python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
+
+DEPEND=">=dev-lang/python-2.0"
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+ distutils_src_install
+ doman scons.1 sconsign.1
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/lib/scons/SCons
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}