summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-02-11 10:55:11 +0000
committerMichael Januszewski <spock@gentoo.org>2004-02-11 10:55:11 +0000
commit417a7828b18e797839f9a3be02010e77ac18ffc6 (patch)
tree8bb1c19d44f42cb0238dd133bd6128679b406ae3 /dev-util
parentversion bump. fixes GTK1 default thanks to Piotr Piasny <p1t3r05 os.pl> and k... (diff)
downloadhistorical-417a7828b18e797839f9a3be02010e77ac18ffc6.tar.gz
historical-417a7828b18e797839f9a3be02010e77ac18ffc6.tar.bz2
historical-417a7828b18e797839f9a3be02010e77ac18ffc6.zip
Sandbox violations fix, closes #40953.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog5
-rw-r--r--dev-util/oprofile/Manifest4
-rw-r--r--dev-util/oprofile/oprofile-0.7.1.ebuild16
3 files changed, 20 insertions, 5 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 82bb0680ef59..9598e2097b1c 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.2 2004/02/01 19:57:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.3 2004/02/11 10:55:11 spock Exp $
+
+ 11 Feb 2004; Michal Januszewski <spock@gentoo.org> oprofile-0.7.1.ebuild:
+ Fixed sandbox violations when emerged with qt USE flag. Closes #40953.
*oprofile-0.7.1 (01 Feb 2004)
diff --git a/dev-util/oprofile/Manifest b/dev-util/oprofile/Manifest
index e3eb81acd7d6..ad36e484ac73 100644
--- a/dev-util/oprofile/Manifest
+++ b/dev-util/oprofile/Manifest
@@ -1,6 +1,6 @@
MD5 93016ca17474020cc5255823c6869e06 oprofile-0.7.ebuild 1655
-MD5 758a403003afaa6fa35dfd2ec9400c94 oprofile-0.7.1.ebuild 1655
-MD5 2c379d71bf7fab63affd2f69edd2fc22 ChangeLog 560
+MD5 4aac2904ff0f85474cc58d5047b8aeef oprofile-0.7.1.ebuild 1931
+MD5 7c052addd021aed788c1d525a4c06c30 ChangeLog 710
MD5 3d4a085e59f4ef22017d52452649205b metadata.xml 310
MD5 8fb81a645cd9dcca67423b0e42d7255c files/digest-oprofile-0.7.1 66
MD5 06028442781220898a045871c9db7de6 files/digest-oprofile-0.7 64
diff --git a/dev-util/oprofile/oprofile-0.7.1.ebuild b/dev-util/oprofile/oprofile-0.7.1.ebuild
index ba517399671b..1029c805b7fe 100644
--- a/dev-util/oprofile/oprofile-0.7.1.ebuild
+++ b/dev-util/oprofile/oprofile-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.1.ebuild,v 1.1 2004/02/01 19:57:28 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.1.ebuild,v 1.2 2004/02/11 10:55:11 spock Exp $
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -21,7 +21,19 @@ src_compile() {
local myconf=""
- use qt || myconf="${myconf} --with-qt-dir=/void"
+ if [ `use qt` ]
+ then
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
myconf="${myconf} --with-x"
# note: compilation has only been tested with a 2.4 kernel