summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-09 01:57:07 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-09 01:57:07 +0000
commit9c5f773c51b3082b47268081900649b3a0c687d5 (patch)
tree9efc9e0e4f9590f5b7dc95c722d3f7f44bd51cb0 /eclass/distutils-r1.eclass
parentBump. (diff)
downloadhistorical-9c5f773c51b3082b47268081900649b3a0c687d5.tar.gz
historical-9c5f773c51b3082b47268081900649b3a0c687d5.tar.bz2
historical-9c5f773c51b3082b47268081900649b3a0c687d5.zip
Stub-out ez_setup.py and distribute_setup.py to prevent packages from downloading their own copy of setuptools.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass11
1 files changed, 10 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 34637665bacd..c35022cce158 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.71 2013/05/21 01:31:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.72 2013/07/09 01:57:07 floppym Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -308,6 +308,12 @@ distutils_install_for_testing() {
esetup.py "${add_args[@]}"
}
+_disable_ez_setup() {
+ local stub="def use_setuptools(*args, **kwargs): pass"
+ [[ -f ez_setup.py ]] && echo "${stub}" > ez_setup.py
+ [[ -f distribute_setup.py ]] && echo "${stub}" > distribute_setup.py
+}
+
# @FUNCTION: distutils-r1_python_prepare_all
# @DESCRIPTION:
# The default python_prepare_all(). It applies the patches from PATCHES
@@ -330,6 +336,9 @@ distutils-r1_python_prepare_all() {
fi
fi
+ # Prevent packages from downloading their own copy of setuptools
+ _disable_ez_setup
+
if [[ ${DISTUTILS_IN_SOURCE_BUILD} && ! ${DISTUTILS_SINGLE_IMPL} ]]
then
# create source copies for each implementation