summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-18 04:08:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-18 04:08:39 +0000
commit2ef6a8ff45219fb62c4fd73f65623c380b532172 (patch)
tree9fbd5dcd11ee4a41a0e2aa8bfb833f8ab3d6895a /games-action/barrage/barrage-1.0.2-r1.ebuild
parentRespect LDFLAGS (bug #335968), CC by deploying autotools. Fix some compiler w... (diff)
downloadhistorical-2ef6a8ff45219fb62c4fd73f65623c380b532172.tar.gz
historical-2ef6a8ff45219fb62c4fd73f65623c380b532172.tar.bz2
historical-2ef6a8ff45219fb62c4fd73f65623c380b532172.zip
fix buffer size (bug #337745) with patch from Kevin Pyle; EAPI=2
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-action/barrage/barrage-1.0.2-r1.ebuild')
-rw-r--r--games-action/barrage/barrage-1.0.2-r1.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/games-action/barrage/barrage-1.0.2-r1.ebuild b/games-action/barrage/barrage-1.0.2-r1.ebuild
index 531865f5c873..5626e4b2f2c8 100644
--- a/games-action/barrage/barrage-1.0.2-r1.ebuild
+++ b/games-action/barrage/barrage-1.0.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/barrage/barrage-1.0.2-r1.ebuild,v 1.7 2008/06/29 12:34:22 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/barrage/barrage-1.0.2-r1.ebuild,v 1.8 2010/09/18 04:08:39 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A violent point-and-click shooting game"
@@ -14,23 +15,29 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2
+DEPEND=">=media-libs/libsdl-1.2[audio,video]
>=media-libs/sdl-mixer-1.2.4"
src_unpack() {
unpack ${P}.tar.gz
}
-src_compile() {
- egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
- emake || die "emake failed"
+src_prepare() {
+ # bug #337745
+ sed -i \
+ -e 's/name\[20\]/name[24]/' \
+ src/menu.h || die
+}
+
+src_configure() {
+ egamesconf --datadir="${GAMES_DATADIR_BASE}"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS ChangeLog README
doicon "${DISTDIR}"/${PN}.png
- make_desktop_entry ${PN} Barrage ${PN}
+ make_desktop_entry ${PN} Barrage
rm "${D}"/usr/share/applications/${PN}.desktop
prepgamesdirs
}