summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-20 08:16:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-20 08:16:02 +0000
commit35c9989b7b490365a38269591ad468171a75ecaf (patch)
tree2f0be1eab4f822a5fd6ea7b9a881fbf4ad6ff05e /games-action
parenttidy (diff)
downloadhistorical-35c9989b7b490365a38269591ad468171a75ecaf.tar.gz
historical-35c9989b7b490365a38269591ad468171a75ecaf.tar.bz2
historical-35c9989b7b490365a38269591ad468171a75ecaf.zip
add two patches from basic (bug #66718)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/atanks/ChangeLog6
-rw-r--r--games-action/atanks/Manifest5
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild5
-rw-r--r--games-action/atanks/files/1.1.0-gentoo.patch107
4 files changed, 118 insertions, 5 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 5c0bce20d184..8686259618b4 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/atanks
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.10 2004/10/31 21:53:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.11 2004/11/20 08:16:02 mr_bones_ Exp $
+
+ 20 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/1.1.0-gentoo.patch, atanks-1.1.0.ebuild:
+ add two patches from basic (bug #66718)
01 Nov 2004; Joseph Jezak <josejx@gentoo.org> atanks-1.1.0.ebuild:
Marked ~ppc
diff --git a/games-action/atanks/Manifest b/games-action/atanks/Manifest
index 1d52f00d8e03..9df49919df71 100644
--- a/games-action/atanks/Manifest
+++ b/games-action/atanks/Manifest
@@ -1,5 +1,6 @@
-MD5 0645e35ce5413f0d6f1261130f3626d0 ChangeLog 2442
-MD5 adfcc2796e236837ddd7f2e1d3ff16d9 atanks-1.1.0.ebuild 1347
+MD5 521a657318c18dd76652ea1a941fd5e4 ChangeLog 2593
+MD5 b9914a97801bf1673c6f191d71ff6428 atanks-1.1.0.ebuild 1392
MD5 08031c6325250ddda0a99870f53c032d metadata.xml 220
MD5 f1a4b436c0ef59132f761306104d2904 files/atanks-gcc34.patch 1229
MD5 ea52207aee01685ed0e4b52b4cd66958 files/digest-atanks-1.1.0 65
+MD5 e3857ce0d93e17bc2ad85dca19571131 files/1.1.0-gentoo.patch 5379
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
index af4231033289..4bc4d0a6dbb0 100644
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.7 2004/10/31 21:53:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.8 2004/11/20 08:16:02 mr_bones_ Exp $
inherit eutils gcc games
-DATA_DIR="${GAMES_DATADIR}/${PN}"
DESCRIPTION="Worms and Scorched Earth-like game"
HOMEPAGE="http://atanks.sourceforge.net/"
SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
@@ -28,7 +27,9 @@ src_unpack() {
then
epatch "${FILESDIR}/atanks-gcc34.patch"
fi
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
+ DATA_DIR="${GAMES_DATADIR}/${PN}"
sed -i \
-e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" \
src/Makefile \
diff --git a/games-action/atanks/files/1.1.0-gentoo.patch b/games-action/atanks/files/1.1.0-gentoo.patch
new file mode 100644
index 000000000000..3ad775640f2c
--- /dev/null
+++ b/games-action/atanks/files/1.1.0-gentoo.patch
@@ -0,0 +1,107 @@
+Index: src/explosion.cc
+===================================================================
+RCS file: /cvsroot/atanks/atanks/src/explosion.cc,v
+retrieving revision 1.12
+diff -u -r1.12 explosion.cc
+--- src/explosion.cc 1 Feb 2004 23:29:28 -0000 1.12
++++ src/explosion.cc 10 Oct 2004 20:14:03 -0000
+@@ -159,7 +159,7 @@
+ }
+ if (distance <= (radius + TANKHEIGHT/2) && tank->l > 0) {
+ _global->updateMenu = 1;
+- tank->damage = (int) ((float) damage * ((float) 1 - ((fabs (distance) / (float)radius) / 2)) * player->damageMultiplier);
++ tank->damage = (int) ((player ? (float) damage * player->damageMultiplier : (float) damage) * ((float) 1 - ((fabs (distance) / (float)radius) / 2)));
+
+ tank->creditTo = player;
+ tank->applyDamage ();
+@@ -253,7 +253,7 @@
+ if (a > 1 && a <= EXPLODEFRAMES + 1) {
+ int startCirc = (radius / EXPLODEFRAMES) * a;
+ circlefill (_env->terrain, (int)x, (int)y, startCirc, PINK);
+- circle (dest, (int)x, (int)y, startCirc, player->color);
++ circle (dest, (int)x, (int)y, startCirc, player ? player->color : WHITE);
+ setUpdateArea ((int)x - (radius + 1), (int)y - (radius + 1), (radius + 1) * 2, (radius + 1) * 2);
+ }
+ } else if ((type >= RIOT_CHARGE) && (type <= RIOT_BLAST)) {
+@@ -261,7 +261,7 @@
+ double sx = x - _global->slope[angle][0] * 15;
+ double sy = y - _global->slope[angle][1] * 15;
+ int startCirc = (radius / EXPLODEFRAMES) * a;
+- triangle (dest, (int)sx, (int)sy, (int)(sx + _global->slope[(angle + 45) % 360][0] * startCirc), (int)(sy + _global->slope[(angle + 45) % 360][1] * startCirc),(int)(sx + _global->slope[(angle + 315) % 360][0] * startCirc),(int)(sy + _global->slope[(angle + 315) % 360][1] * startCirc), player->color);
++ triangle (dest, (int)sx, (int)sy, (int)(sx + _global->slope[(angle + 45) % 360][0] * startCirc), (int)(sy + _global->slope[(angle + 45) % 360][1] * startCirc),(int)(sx + _global->slope[(angle + 315) % 360][0] * startCirc),(int)(sy + _global->slope[(angle + 315) % 360][1] * startCirc), player ? player->color : WHITE);
+ setUpdateArea ((int)sx - (startCirc + 1), (int)sy - (startCirc + 1), (startCirc + 1) * 2, (startCirc + 1) * 2);
+ }
+ } else {
+Index: src/beam.cc
+===================================================================
+RCS file: /cvsroot/atanks/atanks/src/beam.cc,v
+retrieving revision 1.6
+diff -u -r1.6 beam.cc
+--- src/beam.cc 4 Feb 2004 23:34:33 -0000 1.6
++++ src/beam.cc 10 Oct 2004 20:14:03 -0000
+@@ -167,7 +167,7 @@
+ if (targetX > ltank->x - TANKWIDTH - radius && targetX < ltank->x + TANKWIDTH + radius && targetY > ltank->y - radius && targetY < ltank->y + TANKHEIGHT + radius && ltank->l > 0) {
+ //hitSomething = 1;
+ ltank->requireUpdate ();
+- ltank->damage += damage * player->damageMultiplier;
++ ltank->damage += player ? damage * player->damageMultiplier : damage;
+ ltank->creditTo = player;
+ if (destroy)
+ ltank->applyDamage ();
+Index: src/tank.cc
+===================================================================
+RCS file: /cvsroot/atanks/atanks/src/tank.cc,v
+retrieving revision 1.20
+diff -u -r1.20 tank.cc
+--- src/tank.cc 1 Feb 2004 23:29:28 -0000 1.20
++++ src/tank.cc 10 Oct 2004 20:13:18 -0000
+@@ -171,7 +171,8 @@
+ sh -= (int)damage;
+ if (creditTo) {
+ if (player != creditTo) { //enemy hit ++
+- creditTo->money += (int)(damage * _global->scoreHitUnit);
++ double money = damage * _global->scoreHitUnit;
++ creditTo->money += (money < LONG_MAX ? (int)money : LONG_MAX);
+ if ((int)player->type != HUMAN_PLAYER) {
+ if (player->revenge == creditTo) {
+ player->annoyanceFactor += damage;
+Index: src/atanks.cc
+===================================================================
+RCS file: /cvsroot/atanks/atanks/src/atanks.cc,v
+retrieving revision 1.57
+diff -u -r1.57 atanks.cc
+--- src/atanks.cc 4 Feb 2004 23:34:33 -0000 1.57
++++ src/atanks.cc 10 Oct 2004 20:13:18 -0000
+@@ -1574,7 +1574,8 @@
+ fi = global->stopwindow = updatename = scroll = 1;
+ if (global->currentround != global->rounds) {
+ for (z = 0; z < global->numPlayers; z++) {
+- global->players[z]->money = (long int) (global->players[z]->money * global->interest);
++ double money = global->players[z]->money * global->interest;
++ global->players[z]->money = (money < LONG_MAX ? (long int) money : LONG_MAX);
+ }
+ }
+
+@@ -2764,9 +2765,11 @@
+ ltank->explode ();
+ if (ltank->creditTo) {
+ if (ltank->player != ltank->creditTo) { //enemy destroyed
+- ltank->creditTo->money += (int)global->scoreUnitDestroyBonus;
++ double money = ltank->creditTo->money + global->scoreUnitDestroyBonus;
++ ltank->creditTo->money = (money < LONG_MAX ? (long int)money : LONG_MAX);
+ } else { //self destroy - ugh foolish one :))
+ ltank->creditTo->money -= (int)global->scoreUnitSelfDestroy;
++ if (ltank->creditTo->money < 0) ltank->creditTo->money = 0;
+ }
+ ltank->creditTo = NULL;
+ }
+@@ -2808,7 +2811,8 @@
+ if (winner >= 0) {
+ global->players[winner]->score++;
+ global->players[winner]->won++;
+- global->players[winner]->money += (long int)global->scoreRoundWinBonus;
++ double money = global->players[winner]->money + global->scoreRoundWinBonus;
++ global->players[winner]->money = (money < LONG_MAX ? (long int) money : LONG_MAX);
+ }
+ bCount = 0;
+ global->updateMenu = 1;