summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-01-06 00:11:23 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-01-06 00:11:23 +0000
commit43041bc130ab6b96c2b36de89e14a51d6f154115 (patch)
tree932c56017e97dc6388f6bfcac1941529d7de7dd9 /games-arcade/pycadia/pycadia-0.5.1.ebuild
parentold (diff)
downloadhistorical-43041bc130ab6b96c2b36de89e14a51d6f154115.tar.gz
historical-43041bc130ab6b96c2b36de89e14a51d6f154115.tar.bz2
historical-43041bc130ab6b96c2b36de89e14a51d6f154115.zip
Adding wrapper check for dropped keywords (bug #103056)
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'games-arcade/pycadia/pycadia-0.5.1.ebuild')
-rw-r--r--games-arcade/pycadia/pycadia-0.5.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-arcade/pycadia/pycadia-0.5.1.ebuild b/games-arcade/pycadia/pycadia-0.5.1.ebuild
index 2f354e32112c..b8ac934ab32b 100644
--- a/games-arcade/pycadia/pycadia-0.5.1.ebuild
+++ b/games-arcade/pycadia/pycadia-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pycadia/pycadia-0.5.1.ebuild,v 1.7 2005/08/05 19:18:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pycadia/pycadia-0.5.1.ebuild,v 1.8 2006/01/06 00:11:23 compnerd Exp $
inherit games
@@ -20,9 +20,11 @@ S=${WORKDIR}/${PN}
pkg_setup() {
# bug #101464
- if ! built_with_use dev-python/pygtk gnome ; then
- einfo "${PN} needs gnome support in dev-python/pygtk"
- die "Please emerge dev-python/pygtk with USE=gnome"
+ if has_version '<dev-python/pygtk-2.8.0-r2' ; then
+ if ! built_with_use dev-python/pygtk gnome ; then
+ einfo "${PN} needs gnome support in dev-python/pygtk"
+ die "Please emerge dev-python/pygtk with USE=gnome"
+ fi
fi
games_pkg_setup
}