summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-07 01:21:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-07 01:21:05 +0000
commita9fe990c74cb7163d91b93f26699dcb522b95e99 (patch)
treeb03fecd6bd6121fb88589718d440bd9d296548c1 /games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
parentVersion bump (diff)
downloadhistorical-a9fe990c74cb7163d91b93f26699dcb522b95e99.tar.gz
historical-a9fe990c74cb7163d91b93f26699dcb522b95e99.tar.bz2
historical-a9fe990c74cb7163d91b93f26699dcb522b95e99.zip
EAPI=2; tidy
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'games-board/pouetchess/pouetchess-0.2.0-r1.ebuild')
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild43
1 files changed, 18 insertions, 25 deletions
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
index 038048ef524d..3bc8f5a83060 100644
--- a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.6 2008/07/20 20:49:15 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.7 2009/04/07 01:21:05 mr_bones_ Exp $
-inherit base eutils toolchain-funcs games
+EAPI=2
+inherit eutils games
MY_PN=${PN/c/C}
DESCRIPTION="3D and open source chess game"
@@ -15,31 +16,20 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE="debug"
RDEPEND="media-libs/libsdl
- media-libs/sdl-image
+ media-libs/sdl-image[jpeg,png]
virtual/glu
virtual/opengl"
DEPEND="${RDEPEND}
dev-util/scons"
S=${WORKDIR}/${PN}_src_${PV}
-PATCHES=( "${FILESDIR}/${P}-sconstruct-sandbox.patch"
- "${FILESDIR}/${P}-nvidia_glext.patch"
- "${FILESDIR}/${P}-segfaults.patch"
- "${FILESDIR}/${P}-gcc43.patch" )
+PATCHES=( "${FILESDIR}/${P}-sconstruct-sandbox.patch"
+ "${FILESDIR}/${P}-nvidia_glext.patch"
+ "${FILESDIR}/${P}-segfaults.patch"
+ "${FILESDIR}/${P}-gcc43.patch" )
-pkg_setup() {
- games_pkg_setup
- einfo "If you experience problems building pouetchess with nvidia drivers,"
- einfo "you can try:"
- einfo "eselect opengl set xorg-x11"
- einfo "emerge pouetchess"
- einfo "eselect opengl set nvidia"
-}
-
-src_unpack() {
- base_src_unpack
-
- cd "${S}"
+src_prepare() {
+ epatch "${PATCHES[@]}"
# Fix for LibSDL >= 1.2.10 detection
sed -i \
-e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \
@@ -47,9 +37,7 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
- tc-export CC CXX
-
+src_configure() {
# turn off the hackish optimization setting code (bug #230127)
scons configure \
strip=false \
@@ -58,7 +46,12 @@ src_compile() {
datadir="${GAMES_DATADIR}"/${PN} \
$(use debug && echo debug=1) \
|| die "scons configure failed"
- scons || die "scons failed"
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
+
+ scons ${sconsopts} || die "scons failed"
}
src_install() {