summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-06-05 05:01:29 +0000
committerTristan Heaven <tristan@gentoo.org>2007-06-05 05:01:29 +0000
commitdade9b616a6fb01728f2eec2301ba2365f8b9ff1 (patch)
tree9e74cb6a55cb987d71939c006df71489c03c4b16 /games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
parentMarked ~hppa (bug #163285). (diff)
downloadhistorical-dade9b616a6fb01728f2eec2301ba2365f8b9ff1.tar.gz
historical-dade9b616a6fb01728f2eec2301ba2365f8b9ff1.tar.bz2
historical-dade9b616a6fb01728f2eec2301ba2365f8b9ff1.zip
Add segfaults patch from Debian for bug #180427
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'games-board/pouetchess/pouetchess-0.2.0-r1.ebuild')
-rw-r--r--games-board/pouetchess/pouetchess-0.2.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..6d3afabc0bf0
--- /dev/null
+++ b/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pouetchess/pouetchess-0.2.0-r1.ebuild,v 1.1 2007/06/05 05:01:29 nyhm Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_PN=${PN/c/C}
+DESCRIPTION="3D and open source chess game"
+HOMEPAGE="http://pouetchess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_src_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${PN}_src_${PV}
+
+pkg_setup() {
+ games_pkg_setup
+ einfo "If you experience problems building pouetchess with nvidia drivers,"
+ einfo "you can try:"
+ einfo "eselect opengl set xorg-x11"
+ einfo "emerge pouetchess"
+ einfo "eselect opengl set nvidia"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-sconstruct-sandbox.patch \
+ "${FILESDIR}"/${P}-nvidia_glext.patch \
+ "${FILESDIR}"/${P}-segfaults.patch
+
+ # Fix for LibSDL >= 1.2.10 detection
+ sed -i \
+ -e "s:sdlver.split('.') >= \['1','2','8'\]:sdlver.split('.') >= [1,2,8]:" \
+ pouetChess.py \
+ || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC CXX
+ scons configure \
+ strip=false \
+ prefix="${GAMES_PREFIX}" \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) \
+ || die "scons configure failed"
+ scons || die "scons failed"
+}
+
+src_install() {
+ dogamesbin bin/${MY_PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+
+ dodoc ChangeLog README
+
+ doicon data/icons/${MY_PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}.png "KDE;Qt;Game;BoardGame"
+
+ prepgamesdirs
+}