summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-09 19:16:01 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-09 19:16:01 +0000
commitd305e465b93ac7a28818c4de4af6d30a0a9044ef (patch)
treebf122f6f94c29fb9d13ed00b5c8ed749ca5ab497 /games-emulation/higan/files
parentinitial import wrt #254471 (diff)
downloadhistorical-d305e465b93ac7a28818c4de4af6d30a0a9044ef.tar.gz
historical-d305e465b93ac7a28818c4de4af6d30a0a9044ef.tar.bz2
historical-d305e465b93ac7a28818c4de4af6d30a0a9044ef.zip
initial import wrt #254471
Package-Manager: portage-2.2.0_alpha178/cvs/Linux x86_64 Manifest-Sign-Key: 0xE73C35B3
Diffstat (limited to 'games-emulation/higan/files')
-rw-r--r--games-emulation/higan/files/higan-092-QA.patch48
-rw-r--r--games-emulation/higan/files/higan-wrapper7
2 files changed, 55 insertions, 0 deletions
diff --git a/games-emulation/higan/files/higan-092-QA.patch b/games-emulation/higan/files/higan-092-QA.patch
new file mode 100644
index 000000000000..448bd20a3400
--- /dev/null
+++ b/games-emulation/higan/files/higan-092-QA.patch
@@ -0,0 +1,48 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Jun 9 10:23:38 UTC 2013
+Subject:
+
+--- higan_v092-source/higan/Makefile
++++ higan_v092-source/higan/Makefile
+@@ -16,8 +16,8 @@
+ # compiler
+ c := $(compiler) -std=gnu99
+ cpp := $(subst cc,++,$(compiler)) -std=gnu++0x
+-flags := -I. -O3 -fomit-frame-pointer
+-link := -s
++flags := -I.
++link := $(LDFLAGS)
+ objects := libco
+
+ # profile-guided optimization mode
+@@ -33,7 +33,6 @@
+
+ # platform
+ ifeq ($(platform),x)
+- flags += -march=native
+ link += -Wl,-export-dynamic -ldl -lX11 -lXext
+ else ifeq ($(platform),win)
+ ifeq ($(arch),win32)
+@@ -57,9 +56,9 @@
+ compile = \
+ $(strip \
+ $(if $(filter %.c,$<), \
+- $(c) $(flags) $1 -c $< -o $@, \
++ $(c) $(flags) $(CFLAGS) $1 -c $< -o $@, \
+ $(if $(filter %.cpp,$<), \
+- $(cpp) $(flags) $1 -c $< -o $@ \
++ $(cpp) $(flags) $(CXXFLAGS) $1 -c $< -o $@ \
+ ) \
+ ) \
+ )
+--- higan_v092-source/higan/target-ethos/Makefile
++++ higan_v092-source/higan/target-ethos/Makefile
+@@ -67,7 +67,7 @@
+ # targets
+ build: $(objects)
+ ifeq ($(platform),x)
+- $(strip $(cpp) -o out/$(name) $(objects) $(link))
++ $(strip $(cpp) $(CXXFLAGS) -o out/$(name) $(objects) $(link))
+ else ifeq ($(platform),win)
+ $(strip $(cpp) -shared -o out/phoenix.dll obj/phoenix.o $(phoenixlink))
+ $(strip $(cpp) -o out/$(name) $(subst obj/phoenix.o,,$(objects)) $(link) -Lout -lphoenix)
diff --git a/games-emulation/higan/files/higan-wrapper b/games-emulation/higan/files/higan-wrapper
new file mode 100644
index 000000000000..e2d9257a4b65
--- /dev/null
+++ b/games-emulation/higan/files/higan-wrapper
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+[ -e $HOME/.config/ ] || mkdir $HOME/.config/
+
+cp -ru "%GAMES_DATADIR%/higan" $HOME/.config/
+
+exec ${0}.bin "$@"