summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commit4449c749e4d0a531f4dffcd6bd11772e59ecbf81 (patch)
tree47ac23a46562d1736503b9b2447f81b34199c04e /games-emulation/ps2emu-gssoft
parentNew package - rename. (diff)
downloadhistorical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.gz
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.tar.bz2
historical-4449c749e4d0a531f4dffcd6bd11772e59ecbf81.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/ps2emu-gssoft')
-rw-r--r--games-emulation/ps2emu-gssoft/ChangeLog8
-rw-r--r--games-emulation/ps2emu-gssoft/Manifest4
-rw-r--r--games-emulation/ps2emu-gssoft/files/0.5-makefile.patch21
-rw-r--r--games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.51
-rw-r--r--games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.5.ebuild48
5 files changed, 82 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-gssoft/ChangeLog b/games-emulation/ps2emu-gssoft/ChangeLog
new file mode 100644
index 000000000000..0cd349fdd469
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/ps2emu-gssoft
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ChangeLog,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+*ps2emu-gssoft-0.5 (14 Aug 2003)
+
+ 14 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-emulation/ps2emu-gssoft/Manifest b/games-emulation/ps2emu-gssoft/Manifest
new file mode 100644
index 000000000000..4f4e57d6ea9e
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/Manifest
@@ -0,0 +1,4 @@
+MD5 01d21af1bbe9f5f447154e46a7430496 files/0.5-makefile.patch 806
+MD5 4a8e97848fc551a45b1e00021333f575 files/digest-ps2emu-gssoft-0.5 59
+MD5 55be2ca071ba2aed212a8aa34e371497 ChangeLog 365
+MD5 d4e2541ed16700c30805d57fcfc18fe9 ps2emu-gssoft-0.5.ebuild 1085
diff --git a/games-emulation/ps2emu-gssoft/files/0.5-makefile.patch b/games-emulation/ps2emu-gssoft/files/0.5-makefile.patch
new file mode 100644
index 000000000000..c0e79a8d0c75
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/files/0.5-makefile.patch
@@ -0,0 +1,21 @@
+--- Src/Linux/Makefile.orig 2003-08-14 13:11:45.664823032 -0400
++++ Src/Linux/Makefile 2003-08-14 13:13:07.997306592 -0400
+@@ -5,13 +5,17 @@
+ VERSION = 0
+ BUILD = 5
+ PLUGIN = libGSsoftx-${VERSION}.${BUILD}.so
+-CFLAGS+= -fPIC -Wall -O3 -fomit-frame-pointer -I. -I..
++CFLAGS+= -fPIC -Wall $(OPTFLAGS) -I. -I..
+ OBJS = ../GS.o ../Prim.o ../Soft.o ../Draw.o ../Texts.o ../Color.o
+ OBJS+= X11.o Conf.o interface.o support.o DrawString.o
+ DEPS:= $(OBJS:.o=.d)
+ LIBS = $(shell gtk-config --libs) -lX11
+ CFLAGS+= $(shell gtk-config --cflags) -D__LINUX__ -DVERSION=${VERSION} -DBUILD=${BUILD}
+
++ifeq (${USE_SDL},1)
++ CFLAGS+= $(shell sdl-config --cflags) -I../../nsx2/ -I../../nsx2/iniapi
++ LIBS+= $(shell sdl-config --libs)
++endif
+ ifeq (${USE_DGA2}, TRUE)
+ CFLAGS+= -DUSE_DGA2
+ LIBS+= -lXxf86dga
diff --git a/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.5 b/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.5
new file mode 100644
index 000000000000..8a4eb33b1d8f
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/files/digest-ps2emu-gssoft-0.5
@@ -0,0 +1 @@
+MD5 0c9bbadca3b483a68b785c8ba61f29cf Gssoft-0.5.zip 188616
diff --git a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.5.ebuild b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.5.ebuild
new file mode 100644
index 000000000000..691085c74f6c
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.5.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 GPU plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.4release/Gssoft-${PV}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/opengl
+ virtual/x11"
+# sdl? ( media-libs/libsdl )"
+
+S=${WORKDIR}/GSsoft-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ cd Src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die "building X"
+ mv lib* ${S}/
+ #requires stuff from nSX2 which atm is win32 only
+ #if [ `use sdl` ] ; then
+ # cd ..
+ # ln -s GS.h gs.h
+ # epatch ${FILESDIR}/${PV}-sdl.patch
+ # mv Linux-SDL/* Linux/
+ # cd Linux
+ # make clean || die "making clean"
+ # emake OPTFLAGS="${CFLAGS}" || die "building sdl"
+ #fi
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ doexe lib*
+ prepgamesdirs
+}