summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-04 04:39:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-04 04:39:36 +0000
commit310760e0ba3e4f0dbce2a46fc973515be9ab739e (patch)
treee5b0c80d6bbde70e464aa0da2b3f851ae4f5b818 /games-emulation/snes9x
parentStable on mips. (diff)
downloadhistorical-310760e0ba3e4f0dbce2a46fc973515be9ab739e.tar.gz
historical-310760e0ba3e4f0dbce2a46fc973515be9ab739e.tar.bz2
historical-310760e0ba3e4f0dbce2a46fc973515be9ab739e.zip
attempt at fixing bug #48859
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/ChangeLog5
-rw-r--r--games-emulation/snes9x/Manifest4
-rw-r--r--games-emulation/snes9x/snes9x-1.42-r1.ebuild11
3 files changed, 13 insertions, 7 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 5c07778867cc..b6b884beee5a 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/snes9x
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.9 2004/05/03 19:09:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.10 2004/06/04 04:39:36 mr_bones_ Exp $
+
+ 03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> snes9x-1.42-r1.ebuild:
+ attempt at fixing bug #48859
03 May 2004; Michael Sterrett <mr_bones_@gentoo.org> snes9x-1.42.ebuild:
clean old ebuild
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index f1749172d864..63c209d39757 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,5 +1,5 @@
-MD5 1bb23f19915cf16d9fd231bf26b2fd4a ChangeLog 2726
-MD5 3d86381a9fcea9a3ff57927b83989c02 snes9x-1.42-r1.ebuild 1694
+MD5 f904bbaab28248cf9b5d5a44d4143dcb ChangeLog 2836
+MD5 1951a2a2ded803d369d70c63ce060938 snes9x-1.42-r1.ebuild 1818
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 12216340a66b7cfccf1891ca058d9335 files/nojoy.patch 507
MD5 82847f439abd1f8ae87876515e60ccdf files/1.42-system-zlib.patch 2004
diff --git a/games-emulation/snes9x/snes9x-1.42-r1.ebuild b/games-emulation/snes9x/snes9x-1.42-r1.ebuild
index 46658eec28f5..d7d3cd8ad31d 100644
--- a/games-emulation/snes9x/snes9x-1.42-r1.ebuild
+++ b/games-emulation/snes9x/snes9x-1.42-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.42-r1.ebuild,v 1.2 2004/04/27 21:07:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.42-r1.ebuild,v 1.3 2004/06/04 04:39:36 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
HOMEPAGE="http://www.snes9x.com/"
@@ -52,13 +52,16 @@ src_compile() {
target=snes9x;;
esac
# this stuff is ugly but hey the build process sucks ;)
+ OPTFLAGS="${CXXFLAGS} -DHAVE_LIBPNG" \
egamesconf \
--with-screenshot \
$(use_with joystick) \
${vidconf} \
$(use_with x86 assembler) \
|| die
- emake ${target} || die "making ${target}"
+ emake \
+ EXTRALIBS="$(libpng-config --libs) -lpthread" \
+ ${target} || die "making ${target}"
mv ${target} "${S}/mybins/"
cd "${WORKDIR}"
rm -rf "${S}/snes9x"
@@ -67,7 +70,7 @@ src_compile() {
}
src_install() {
- dogamesbin mybins/*
+ dogamesbin mybins/* || die "dogamesbin failed"
dodoc faqs.txt readme.txt readme.unix snes9x/*.txt
prepgamesdirs
}