summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-04-06 18:56:48 +0000
committerTristan Heaven <tristan@gentoo.org>2007-04-06 18:56:48 +0000
commit6201cd898f809b97a7216710a188f9cb5ae988a0 (patch)
treeb1d5593094962d0a8e7d70b46c88b0dcae9a7d17 /games-emulation
parentMark 0.4.3-r2 stable on amd64 and x86 as it is identical to -r1 and makes sur... (diff)
downloadhistorical-6201cd898f809b97a7216710a188f9cb5ae988a0.tar.gz
historical-6201cd898f809b97a7216710a188f9cb5ae988a0.tar.bz2
historical-6201cd898f809b97a7216710a188f9cb5ae988a0.zip
use games_get_libdir
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx2/pcsx2-0.6.ebuild10
-rw-r--r--games-emulation/pcsx2/pcsx2-0.8.1.ebuild6
-rw-r--r--games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild13
3 files changed, 15 insertions, 14 deletions
diff --git a/games-emulation/pcsx2/pcsx2-0.6.ebuild b/games-emulation/pcsx2/pcsx2-0.6.ebuild
index 30f40f21f5e7..14e3929258cf 100644
--- a/games-emulation/pcsx2/pcsx2-0.6.ebuild
+++ b/games-emulation/pcsx2/pcsx2-0.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.7 2006/02/11 19:55:21 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.6.ebuild,v 1.8 2007/04/06 18:53:44 nyhm Exp $
inherit eutils games
@@ -45,11 +45,11 @@ src_install() {
dogamesbin "${FILESDIR}/pcsx2" || die "dogamesbin failed"
sed -i \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
"${D}/${GAMES_BINDIR}/pcsx2" \
|| die "sed failed"
- dodir "${GAMES_LIBDIR}/ps2emu/Langs"
- cp -r Intl/Langs/* "${D}/${GAMES_LIBDIR}/ps2emu/Langs/" || die "cp failed"
+ dodir "$(games_get_libdir)/ps2emu/Langs"
+ cp -r Intl/Langs/* "${D}/$(games_get_libdir)/ps2emu/Langs/" || die "cp failed"
dodoc Docs/*.txt
prepgamesdirs
}
diff --git a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
index b9fc7aba6357..e71690015796 100644
--- a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
+++ b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.7 2006/05/02 21:53:46 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.8 2007/04/06 18:53:44 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -53,7 +53,7 @@ src_install() {
dogamesbin "${FILESDIR}/pcsx2" || die "dogamesbin failed"
sed -i \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
- -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
"${D}/${GAMES_BINDIR}/pcsx2" \
|| die "sed failed"
dodoc Docs/*.txt
diff --git a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
index 131e056d8c04..63a26f608540 100644
--- a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
+++ b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.6 2004/11/03 00:16:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.7 2007/04/06 18:56:48 nyhm Exp $
inherit games
@@ -17,12 +17,13 @@ RDEPEND="=x11-libs/gtk+-1*"
DEPEND="${RDEPEND}
app-arch/unzip"
-S="${WORKDIR}/CDVDlinuz"
+S=${WORKDIR}/CDVDlinuz
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i \
- -e 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/Src/Makefile \
+ -e 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' Src/Makefile \
|| die "sed failed"
}
@@ -33,7 +34,7 @@ src_compile() {
src_install() {
dodoc ReadMe.txt
- exeinto ${GAMES_LIBDIR}/ps2emu/plugins
- newexe Src/libCDVDlinuz.so libCDVDlinuz-${PV}.so
+ exeinto "$(games_get_libdir)"/ps2emu/plugins
+ newexe Src/libCDVDlinuz.so libCDVDlinuz-${PV}.so || die "newexe failed"
prepgamesdirs
}