summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-14 05:29:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-14 05:29:44 +0000
commitbac0c74601d7029c5206a92921ffe6cfa86ee467 (patch)
treeb5ec14f8f4ec1ae96e0472897325c78451d1f6d3 /games-emulation
parentAdd IUSE; tidy (diff)
downloadhistorical-bac0c74601d7029c5206a92921ffe6cfa86ee467.tar.gz
historical-bac0c74601d7029c5206a92921ffe6cfa86ee467.tar.bz2
historical-bac0c74601d7029c5206a92921ffe6cfa86ee467.zip
add eutils for epatch; tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/ChangeLog5
-rw-r--r--games-emulation/openmsx/Manifest8
-rw-r--r--games-emulation/openmsx/openmsx-0.4.0.ebuild19
3 files changed, 17 insertions, 15 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index 55e9a83de479..07afdffba9ec 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/openmsx
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.5 2004/06/12 20:13:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.6 2004/06/14 05:29:44 mr_bones_ Exp $
+
+ 13 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> openmsx-0.4.0.ebuild:
+ add eutils for epatch; tidy
*openmsx-0.4.0 (12 Jun 2004)
diff --git a/games-emulation/openmsx/Manifest b/games-emulation/openmsx/Manifest
index 93184190b4ff..b7f6a33b12d1 100644
--- a/games-emulation/openmsx/Manifest
+++ b/games-emulation/openmsx/Manifest
@@ -1,8 +1,8 @@
-MD5 59b057f094440f9e02e7654077c41c0d openmsx-0.3.4.ebuild 1870
-MD5 51d62681a9d64bd2000f3aea17d191a1 ChangeLog 1017
+MD5 9d9a71a8d70d1e68e393279d592714c2 ChangeLog 1126
MD5 7f1f3c0172523729641ba9bc11dcbe55 metadata.xml 248
-MD5 32105eb1f3d32374c6123081d249ff84 openmsx-0.4.0.ebuild 1211
-MD5 7e488066115ef9f2e653d6260cd2499b files/openmsx-0.4.0-custom.mk.patch 377
+MD5 f5193a3c2eac24fbf6a87195db71a521 openmsx-0.3.4.ebuild 1869
+MD5 ff7279940cddd33cb6c6def660e32180 openmsx-0.4.0.ebuild 1122
MD5 04f5dc7ba36939e792262356a7558ac1 files/digest-openmsx-0.3.4 66
MD5 b55f13765241896c1c13a29faba65874 files/digest-openmsx-0.4.0 65
+MD5 7e488066115ef9f2e653d6260cd2499b files/openmsx-0.4.0-custom.mk.patch 377
MD5 2aa177e70143c6086066c46f58217c69 files/openmsx-0.4.0-symlinking.patch 772
diff --git a/games-emulation/openmsx/openmsx-0.4.0.ebuild b/games-emulation/openmsx/openmsx-0.4.0.ebuild
index 01fe40abafe2..26989039449b 100644
--- a/games-emulation/openmsx/openmsx-0.4.0.ebuild
+++ b/games-emulation/openmsx/openmsx-0.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.4.0.ebuild,v 1.1 2004/06/12 20:13:55 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.4.0.ebuild,v 1.2 2004/06/14 05:29:44 mr_bones_ Exp $
-inherit games flag-o-matic
+inherit flag-o-matic eutils games
DESCRIPTION="MSX emulator that aims for perfection"
HOMEPAGE="http://openmsx.sourceforge.net/"
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc"
IUSE=""
-RDEPEND="dev-lang/tcl
+DEPEND="dev-lang/tcl
dev-libs/libxml2
media-libs/libpng
sys-libs/zlib
@@ -22,32 +22,31 @@ RDEPEND="dev-lang/tcl
media-libs/libsdl
virtual/x11
virtual/opengl"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-custom.mk.patch
- epatch ${FILESDIR}/${P}-symlinking.patch
+ epatch "${FILESDIR}/${P}-custom.mk.patch"
+ epatch "${FILESDIR}/${P}-symlinking.patch"
}
src_compile() {
# fix bug 32745
replace-flags -Os -O2
- egamesconf || die "Fatal error in configure script"
+ egamesconf || die
emake || die "Fatal error during compilation"
}
src_install() {
- egamesinstall OPENMSX_INSTALL="${D}/usr/games/openmsx" || die "Fatal error during installation"
+ egamesinstall \
+ OPENMSX_INSTALL="${D}/usr/games/openmsx" || die
dodoc README AUTHORS
dohtml -r doc/*
# Tidy up install
- rm -f ${D}${GAMES_DATADIR}/openmsx/*.{txt,tex,html,png,css}
+ rm -f "${D}${GAMES_DATADIR}/openmsx/"*.{txt,tex,html,png,css}
prepgamesdirs
}