summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 21:12:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 21:12:33 +0000
commit1b5f5955362a35b3f19732b227aff20e207c7093 (patch)
tree75e77f8b54c0d3f9767620c329f5e69bcb54597d /games-fps/unreal
parentversion bump, thanks to jaalexATjasonalexander.us (diff)
downloadhistorical-1b5f5955362a35b3f19732b227aff20e207c7093.tar.gz
historical-1b5f5955362a35b3f19732b227aff20e207c7093.tar.bz2
historical-1b5f5955362a35b3f19732b227aff20e207c7093.zip
switch over to now cdrom interface
Diffstat (limited to 'games-fps/unreal')
-rw-r--r--games-fps/unreal/unreal-226.ebuild51
1 files changed, 40 insertions, 11 deletions
diff --git a/games-fps/unreal/unreal-226.ebuild b/games-fps/unreal/unreal-226.ebuild
index 5076724f4110..fe4a397bb505 100644
--- a/games-fps/unreal/unreal-226.ebuild
+++ b/games-fps/unreal/unreal-226.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/unreal-226.ebuild,v 1.5 2004/02/08 21:06:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/unreal-226.ebuild,v 1.6 2004/02/08 21:12:33 vapier Exp $
inherit games eutils
DESCRIPTION="Futuristic FPS (a hack that runs on top of Unreal Tournament)"
HOMEPAGE="http://www.unreal.com/ http://icculus.org/~chunky/ut/unreal/"
-SRC_URI="http://www.icculus.org/%7Echunky/ut/unreal/unreali-install.run"
+SRC_URI="http://www.icculus.org/%7Echunky/ut/unreal/unreali-install.run
+ ftp://ftp.lokigames.com/pub/patches/ut/ut-install-436.run
+ ftp://ftp.lokigames.com/pub/patches/ut/IpDrv-436-Linux-08-20-02.zip"
LICENSE="as-is"
SLOT="0"
@@ -21,31 +23,58 @@ RDEPEND="X? ( virtual/x11 )
S=${WORKDIR}
pkg_setup() {
- export CDROM_NAME="Unreal Tournament CD"
- cdrom_get_cds System/
+ export CDROM_NAME_1="Unreal CD"
+ export CDROM_NAME_2="Unreal Tournament CD"
+ cdrom_get_cds System/ System/UnrealTournament.ini
games_pkg_setup
}
src_unpack() {
- unpack_makeself ${A}
+ unpack_makeself unreali-install.run
+ mkdir ut
+ cd ut
+ unpack_makeself ut-install-436.run
+ unpack IpDrv-436-Linux-08-20-02.zip
}
src_install() {
local dir=${GAMES_PREFIX_OPT}/unreal
dodir ${dir}
+ tar -zxf ut/data.tar.gz -C ${D}/${dir}
+ tar -zxf ut/OpenGL.ini.tar.gz -C ${D}/${dir}
tar -zxf System.tar.gz -C ${D}/${dir}
+ insinto ${dir}/System
+ doins ut/IpDrv.so
- cp -rf ${GAMES_CD}/{Maps,Music,Sounds} ${D}/${dir}/
+ cp -rf ${CDROM_ROOT}/{Maps,Music,Sounds} ${D}/${dir}/
+ for f in ${D}/${dir}/Maps/Dm*.unr ; do
+ mv ${f} ${f/Dm/DM-}
+ done
+ dosym Maps ${dir}/maps
+
+ if has_version '<games-fps/unreal-tournament-451' \
+ || has_version '<games-fps/unreal-tournament-goty-451' ; then
+ CDROM_ROOT="${GAMES_PREFIX_OPT}/unreal-tournament"
+ else
+ cdrom_load_next_cd
+ fi
+ insinto ${dir}/Textures
+ doins ${CDROM_ROOT}/Textures/*.utx
+ insinto ${dir}/Sounds
+ doins ${CDROM_ROOT}/Sounds/*.uax
+ insinto ${dir}/System
+ doins ${CDROM_ROOT}/System/*.u
+ insinto ${dir}/Music
+ doins ${CDROM_ROOT}/Music/*.umx
insinto ${dir}
doins icon.* README*
- dosym ${GAMES_PREFIX_OPT}/unreal-tournament/System/Engine.so ${dir}/System/Engine.so
- dosym ${GAMES_PREFIX_OPT}/unreal-tournament/System/Core.so ${dir}/System/Core.so
+ exeinto ${dir}
+ doexe bin/x86/unreal
- dogamesbin ${FILESDIR}/unreal
- dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/unreal
+ games_make_wrapper unreal ./unreal ${dir}
prepgamesdirs
}