summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-18 05:52:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-18 05:52:05 +0000
commit7c8160c593dffadf5a0acd43cafe432c092310bd (patch)
tree626383e560a9bac937188272d8e5624ab0645075 /games-fps
parentVersion bump thanks to Christian Heim #112819. (diff)
downloadhistorical-7c8160c593dffadf5a0acd43cafe432c092310bd.tar.gz
historical-7c8160c593dffadf5a0acd43cafe432c092310bd.tar.bz2
historical-7c8160c593dffadf5a0acd43cafe432c092310bd.zip
update snapshot
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/Manifest8
-rw-r--r--games-fps/quake3/files/digest-quake3-1.33_alpha3641
-rw-r--r--games-fps/quake3/quake3-1.33_alpha364.ebuild91
3 files changed, 97 insertions, 3 deletions
diff --git a/games-fps/quake3/Manifest b/games-fps/quake3/Manifest
index 07e9b5da6594..a07ba81a69ed 100644
--- a/games-fps/quake3/Manifest
+++ b/games-fps/quake3/Manifest
@@ -3,12 +3,14 @@ Hash: SHA1
MD5 420d40268fda31888ddc60bdabb37b6c ChangeLog 343
MD5 f0983c11dd15d4a387dd77c2a8173c7a files/digest-quake3-1.33_alpha255 73
+MD5 2dcccc11eb605e8f01d0d9fa34ee6118 files/digest-quake3-1.33_alpha364 73
MD5 0a25a9c85ee385ef578cb770a957756d metadata.xml 954
MD5 383bf3ec28d6ddb48c52140420692aef quake3-1.33_alpha255.ebuild 2359
+MD5 f18be5bd36ab79777367594ac70c8f6e quake3-1.33_alpha364.ebuild 2363
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDatxdgIKl8Uu19MoRAsoXAJ98N5dLarE5X//cZbj3WujqczeNPgCeKBJD
-bh1pFANEZDofcgTWsOjiUjA=
-=AgQs
+iD8DBQFDfWxcgIKl8Uu19MoRArKWAJ9zcDVIZ+8xqY0MY20A+YPfYgjRmwCfUD2r
+uz8XYq250Bl8dF4NebYrJxg=
+=v32J
-----END PGP SIGNATURE-----
diff --git a/games-fps/quake3/files/digest-quake3-1.33_alpha364 b/games-fps/quake3/files/digest-quake3-1.33_alpha364
new file mode 100644
index 000000000000..1c522c64cff5
--- /dev/null
+++ b/games-fps/quake3/files/digest-quake3-1.33_alpha364
@@ -0,0 +1 @@
+MD5 2343dd5306acd0653ef10ad4deeabe91 quake3-1.33_SVN364M.tar.bz2 1903807
diff --git a/games-fps/quake3/quake3-1.33_alpha364.ebuild b/games-fps/quake3/quake3-1.33_alpha364.ebuild
new file mode 100644
index 000000000000..a667e7d20c49
--- /dev/null
+++ b/games-fps/quake3/quake3-1.33_alpha364.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.33_alpha364.ebuild,v 1.1 2005/11/18 05:52:05 vapier Exp $
+
+# quake3-9999 -> latest svn
+# quake3-9999.REV -> use svn REV
+# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-VER -> normal quake release
+
+if [[ ${PV} == 9999* ]] ; then
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
+ ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+ inherit subversion games toolchain-funcs
+
+ SRC_URI=""
+ S=${WORKDIR}/trunk
+elif [[ ${PV} == *_alpha* ]] ; then
+ inherit games toolchain-funcs
+
+ MY_PV=${PV/_alpha*}
+ SNAP=${PV/*_alpha}
+ MY_P=${PN}-${MY_PV}_SVN${SNAP}M
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit games toolchain-funcs
+
+ SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://icculus.org/quake3/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated opengl"
+
+RDEPEND="opengl? ( virtual/opengl virtual/x11 media-libs/libsdl )
+ !dedicated? ( virtual/opengl virtual/x11 media-libs/libsdl )
+ games-fps/quake3-data"
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]] ; then
+ subversion_src_unpack
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ emake \
+ BUILD_SERVER=$(buildit dedicated) \
+ BUILD_CLIENT=$(buildit opengl) \
+ TEMPDIR="${T}" \
+ CC="$(tc-getCC)" \
+ ARCH=$(tc-arch-kernel) \
+ OPTIMIZE="${CFLAGS}" \
+ DEFAULT_BASEDIR="${GAMES_DATADIR}/quake3" \
+ DEFAULT_LIBDIR="${GAMES_LIBDIR}/quake3" \
+ || die
+}
+
+src_install() {
+ dodoc id-readme.txt TODO README BUGS ChangeLog
+ cd code/unix
+ dodoc README.*
+
+ doicon quake3.xpm
+ make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+
+ cd release*
+ for x in linux* ; do
+ newgamesbin ${x} ${x/linux} || die "dobin ${x}"
+ done
+ exeinto ${GAMES_LIBDIR}/${PN}/baseq3
+ doexe baseq3/*.so || die "baseq3 .so"
+ exeinto ${GAMES_LIBDIR}/${PN}/missionpack
+ doexe missionpack/*.so || die "missionpack .so"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "The source version of Quake 3 will not work with Punk Buster."
+ ewarn "If you need pb support, then use the quake3-bin package."
+ echo
+}