summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad House <brad_mssw@gentoo.org>2004-02-15 07:14:54 +0000
committerBrad House <brad_mssw@gentoo.org>2004-02-15 07:14:54 +0000
commit8e13050cb0e37094f50de915c2fac999edc26c0c (patch)
treee7e815ef6576a9f1b4762dd8b82c9f554e17cb19 /games-fps
parentver bump (diff)
downloadhistorical-8e13050cb0e37094f50de915c2fac999edc26c0c.tar.gz
historical-8e13050cb0e37094f50de915c2fac999edc26c0c.tar.bz2
historical-8e13050cb0e37094f50de915c2fac999edc26c0c.zip
fix amd64 install
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/ut2004-demo/Manifest4
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3120.ebuild8
2 files changed, 7 insertions, 5 deletions
diff --git a/games-fps/ut2004-demo/Manifest b/games-fps/ut2004-demo/Manifest
index 1790c8a20051..1a8d7b67da22 100644
--- a/games-fps/ut2004-demo/Manifest
+++ b/games-fps/ut2004-demo/Manifest
@@ -1,4 +1,4 @@
MD5 3166d1907f8e34524caf8f1d6f73cab5 ChangeLog 491
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 98200279c3f9545cc085ad71fa37973d ut2004-demo-3120.ebuild 1154
-MD5 f450660630fe47a1fe15a26022d51cdd files/digest-ut2004-demo-3120 76
+MD5 ee31b07c11059123bde9227164efbfd8 ut2004-demo-3120.ebuild 1244
+MD5 3009f411f0d18bf2977f61b468335bf4 files/digest-ut2004-demo-3120 154
diff --git a/games-fps/ut2004-demo/ut2004-demo-3120.ebuild b/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
index 66f39d45ca38..81223a0da884 100644
--- a/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
+++ b/games-fps/ut2004-demo/ut2004-demo-3120.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ut2004-demo-3120.ebuild,v 1.3 2004/02/15 05:34:01 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-demo/ut2004-demo-3120.ebuild,v 1.4 2004/02/15 07:14:54 brad_mssw Exp $
inherit games eutils
@@ -22,8 +22,10 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
- unpack_makeself ut2004-lnx-demo-${PV}.run
- rm ut2004-lnx-demo-${PV}.run
+ [ "${ARCH}" = "amd64" ] && RNAME="ut2004-lnx64-demo-${PV}.run"
+ [ "${ARCH}" = "x86" ] && RNAME="ut2004-lnx-demo-${PV}.run"
+ unpack_makeself ${RNAME}
+ rm ${RNAME}
}
src_install() {