summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-18 22:14:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-18 22:14:15 +0000
commit93ed59aa882ca1044722706a220f6c6d518f84ce (patch)
treecc35bb6bae15d2e16f010c78792fa722d7a005d6 /games-fps
parentAdded to ~ppc. (diff)
downloadhistorical-93ed59aa882ca1044722706a220f6c6d518f84ce.tar.gz
historical-93ed59aa882ca1044722706a220f6c6d518f84ce.tar.bz2
historical-93ed59aa882ca1044722706a220f6c6d518f84ce.zip
fix #28726 + duke3d.cfg + music
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/duke3d/ChangeLog10
-rw-r--r--games-fps/duke3d/duke3d-20030817.ebuild13
-rw-r--r--games-fps/duke3d/files/duke3d.cfg194
3 files changed, 210 insertions, 7 deletions
diff --git a/games-fps/duke3d/ChangeLog b/games-fps/duke3d/ChangeLog
index b2ca4044f366..7ec2b3eaea0f 100644
--- a/games-fps/duke3d/ChangeLog
+++ b/games-fps/duke3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/duke3d
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.2 2003/09/10 16:05:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/ChangeLog,v 1.3 2003/09/18 22:14:15 vapier Exp $
+
+*duke3d-20030817 (17 Aug 2003)
+
+ 18 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Fixed building issue #28726, added a default duke3d.cfg file,
+ and added timidity to DEPEND so users get midi music.
25 Aug 2003; Michael Sterrett <msterret@gentoo.org> duke3d-20030817.ebuild:
added flag-o-matic; DEPEND on sed >= 4; filter -O3 down to -O2 for bug 26968;
@@ -9,7 +15,5 @@
18 Aug 2003; Chris Gianelloni <wolf31o2@gentoo.org> duke3d-20030817.ebuild:
Fixing dependency. Closing bug #26855
-*duke3d-20030817 (17 Aug 2003)
-
17 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Initial import. Ebuild submitted by me.
diff --git a/games-fps/duke3d/duke3d-20030817.ebuild b/games-fps/duke3d/duke3d-20030817.ebuild
index f6c60558254f..07b1ca8f3af7 100644
--- a/games-fps/duke3d/duke3d-20030817.ebuild
+++ b/games-fps/duke3d/duke3d-20030817.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20030817.ebuild,v 1.1 2003/09/09 18:10:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/duke3d/duke3d-20030817.ebuild,v 1.2 2003/09/18 22:14:15 vapier Exp $
ECVS_PASS="anonymous"
ECVS_SERVER="icculus.org:/cvs/cvsroot"
@@ -20,6 +20,8 @@ DEPEND="virtual/x11
>=sys-apps/sed-4
media-libs/libsdl
media-libs/sdl-mixer
+ media-sound/timidity++
+ media-sound/timidity-eawpatches
opengl? ( virtual/opengl )
!nophysfs? ( dev-games/physfs )"
@@ -48,7 +50,7 @@ src_unpack() {
Makefile
[ `use x86` ] && sed -i 's:^#USE_ASM:USE_ASM:' Makefile
epatch ${FILESDIR}/${PV}-buildengine-makefile-cflags.patch
- sed -i 's:/usr/lib/perl5/i386-linux/CORE/libperl.a:-lperl:' Makefile
+ sed -i 's:/usr/lib/perl5/i386-linux/CORE/libperl.a::' Makefile
# configure duke3d
cd ${S}/source
@@ -62,9 +64,9 @@ src_compile() {
# -O3 fails on athlon with gcc 3.2.3, maybe others.
replace-flags "-O3" "-O2"
cd source/buildengine
- emake OPTFLAGS="${CFLAGS}" || die "emake failed"
+ emake OPTFLAGS="${CFLAGS}" || die "buildengine failed"
cd ..
- emake OPTIMIZE="${CFLAGS}" || die "emake failed"
+ emake OPTIMIZE="${CFLAGS}" || die "duke3d failed"
}
src_install() {
@@ -79,6 +81,9 @@ src_install() {
newins defs.con DEFS.CON
newins game.con GAME.CON
newins user.con USER.CON
+ insinto ${GAMES_SYSCONFDIR}
+ doins ${FILESDIR}/duke3d.cfg
+ dosym ${GAMES_SYSCONFDIR}/duke3d.cfg ${GAMES_DATADIR}/${PN}/DUKE3D.CFG
prepgamesdirs
}
diff --git a/games-fps/duke3d/files/duke3d.cfg b/games-fps/duke3d/files/duke3d.cfg
new file mode 100644
index 000000000000..2e8c4a0671b7
--- /dev/null
+++ b/games-fps/duke3d/files/duke3d.cfg
@@ -0,0 +1,194 @@
+[Setup]
+SetupVersion = "1.3D"
+
+[Screen Setup]
+ScreenMode = 2
+ScreenWidth = 1024
+ScreenHeight = 768
+Shadows = 1
+Password = ""
+Detail = 1
+Tilt = 1
+Messages = 1
+Out = 0
+ScreenSize = 8
+ScreenGamma = 0
+
+[Sound Setup]
+FXDevice = 0
+MusicDevice = 0
+FXVolume = 220
+MusicVolume = 200
+NumVoices = 8
+NumChannels = 2
+NumBits = 16
+MixRate = 44100
+MidiPort = 0x330
+BlasterAddress = 0x220
+BlasterType = 1
+BlasterInterrupt = 5
+BlasterDma8 = 1
+BlasterDma16 = 5
+BlasterEmu = 0x620
+ReverseStereo = 0
+SoundToggle = 1
+VoiceToggle = 1
+AmbienceToggle = 1
+MusicToggle = 1
+
+[KeyDefinitions]
+Move_Forward = "Up" "Kpad8"
+Move_Backward = "Down" "Kpad2"
+Turn_Left = "Left" "Kpad4"
+Turn_Right = "Right" "KPad6"
+Strafe = "LAlt" "RAlt"
+Fire = "LCtrl" "RCtrl"
+Open = "Space" ""
+Run = "LShift" "RShift"
+AutoRun = "CapLck" ""
+Jump = "A" "/"
+Crouch = "Z" ""
+Look_Up = "PgUp" "Kpad9"
+Look_Down = "PgDn" "Kpad3"
+Look_Left = "Insert" "Kpad0"
+Look_Right = "Delete" "Kpad."
+Strafe_Left = "," ""
+Strafe_Right = "." ""
+Aim_Up = "Home" "KPad7"
+Aim_Down = "End" "Kpad1"
+Weapon_1 = "1" ""
+Weapon_2 = "2" ""
+Weapon_3 = "3" ""
+Weapon_4 = "4" ""
+Weapon_5 = "5" ""
+Weapon_6 = "6" ""
+Weapon_7 = "7" ""
+Weapon_8 = "8" ""
+Weapon_9 = "9" ""
+Weapon_10 = "0" ""
+Inventory = "Enter" "KpdEnt"
+Inventory_Left = "[" ""
+Inventory_Right = "]" ""
+Holo_Duke = "H" ""
+Jetpack = "J" ""
+NightVision = "N" ""
+MedKit = "M" ""
+TurnAround = "BakSpc" ""
+SendMessage = "T" ""
+Map = "Tab" ""
+Shrink_Screen = "-" "Kpad-"
+Enlarge_Screen = "=" "Kpad+"
+Center_View = "KPad5" ""
+Holster_Weapon = "ScrLck" ""
+Show_Opponents_Weapon = "W" ""
+Map_Follow_Mode = "F" ""
+See_Coop_View = "K" ""
+Mouse_Aiming = "U" ""
+Toggle_Crosshair = "I" ""
+Steroids = "R" ""
+Quick_Kick = "`" ""
+Next_Weapon = "'" ""
+Previous_Weapon = ";" ""
+
+[Controls]
+ControllerType = 1
+JoystickPort = 0
+MouseSensitivity = 32768
+ExternalFilename = "EXTERNAL.EXE"
+EnableRudder = 0
+MouseAiming = 0
+MouseButton0 = "Fire"
+MouseButtonClicked0 = ""
+MouseButton1 = "Strafe"
+MouseButtonClicked1 = "Open"
+MouseButton2 = "Move_Forward"
+MouseButtonClicked2 = ""
+JoystickButton0 = "Fire"
+JoystickButtonClicked0 = ""
+JoystickButton1 = "Strafe"
+JoystickButtonClicked1 = "Inventory"
+JoystickButton2 = "Run"
+JoystickButtonClicked2 = "Jump"
+JoystickButton3 = "Open"
+JoystickButtonClicked3 = "Crouch"
+JoystickButton4 = "Aim_Down"
+JoystickButtonClicked4 = ""
+JoystickButton5 = "Look_Right"
+JoystickButtonClicked5 = ""
+JoystickButton6 = "Aim_Up"
+JoystickButtonClicked6 = ""
+JoystickButton7 = "Look_Left"
+JoystickButtonClicked7 = ""
+MouseAnalogAxes0 = "analog_turning"
+MouseDigitalAxes0_0 = ""
+MouseDigitalAxes0_1 = ""
+MouseAnalogScale0 = 0
+MouseAnalogAxes1 = "analog_moving"
+MouseDigitalAxes1_0 = ""
+MouseDigitalAxes1_1 = ""
+MouseAnalogScale1 = 0
+JoystickAnalogAxes0 = "analog_turning"
+JoystickDigitalAxes0_0 = ""
+JoystickDigitalAxes0_1 = ""
+JoystickAnalogScale0 = 0
+JoystickAnalogAxes1 = "analog_moving"
+JoystickDigitalAxes1_0 = ""
+JoystickDigitalAxes1_1 = ""
+JoystickAnalogScale1 = 0
+JoystickAnalogAxes2 = "analog_strafing"
+JoystickDigitalAxes2_0 = ""
+JoystickDigitalAxes2_1 = ""
+JoystickAnalogScale2 = 0
+JoystickAnalogAxes3 = ""
+JoystickDigitalAxes3_0 = "Run"
+JoystickDigitalAxes3_1 = ""
+JoystickAnalogScale3 = 0
+GamePadDigitalAxes0_0 = "Turn_Left"
+GamePadDigitalAxes0_1 = "Turn_Right"
+GamePadDigitalAxes1_0 = "Move_Forward"
+GamePadDigitalAxes1_1 = "Move_Backward"
+MouseAimingFlipped = 0
+GameMouseAiming = 0
+AimingFlag = 0
+
+[Comm Setup]
+ComPort = 2
+IrqNumber = 65535
+UartAddress = 65535
+PortSpeed = 9600
+ToneDial = 1
+SocketNumber = 65535
+NumberPlayers = 2
+ModemName = ""
+InitString = "ATZ"
+HangupString = "ATH0=0"
+DialoutString = ""
+PlayerName = "DUKE"
+RTSName = "DUKE.RTS"
+PhoneNumber = ""
+ConnectType = 0
+CommbatMacro#0 = "An inspiration for birth control."
+CommbatMacro#1 = "You're gonna die for that!"
+CommbatMacro#2 = "It hurts to be you."
+CommbatMacro#3 = "Lucky Son of a Bitch."
+CommbatMacro#4 = "Hmmm....Payback time."
+CommbatMacro#5 = "You bottom dwelling scum sucker."
+CommbatMacro#6 = "Damn, you're ugly."
+CommbatMacro#7 = "Ha ha ha...Wasted!"
+CommbatMacro#8 = "You suck!"
+CommbatMacro#9 = "AARRRGHHHHH!!!"
+
+[Misc]
+Executions = 5
+RunMode = 0
+Crosshairs = 1
+WeaponChoice0 = 3
+WeaponChoice1 = 4
+WeaponChoice2 = 5
+WeaponChoice3 = 7
+WeaponChoice4 = 8
+WeaponChoice5 = 6
+WeaponChoice6 = 0
+WeaponChoice7 = 2
+WeaponChoice8 = 9
+WeaponChoice9 = 1