summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-03 15:28:14 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-03 15:28:14 +0000
commitc8c318a2e05f50a87f90d25d504af1e7c439da42 (patch)
tree0e950d2628ccbe98fb4f61124641292ca30cc033 /games-fps
parentInitial import. (diff)
downloadhistorical-c8c318a2e05f50a87f90d25d504af1e7c439da42.tar.gz
historical-c8c318a2e05f50a87f90d25d504af1e7c439da42.tar.bz2
historical-c8c318a2e05f50a87f90d25d504af1e7c439da42.zip
Added filter-flags to remove -mfpmath=sse for bug #149008.
Package-Manager: portage-2.1.2_pre1-r4
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/ChangeLog7
-rw-r--r--games-fps/quake3/quake3-1.34_alpha789.ebuild38
-rw-r--r--games-fps/quake3/quake3-9999.ebuild55
3 files changed, 46 insertions, 54 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index eba013757cbb..c4b7871ef713 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake3
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.41 2006/05/26 01:00:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.42 2006/10/03 15:28:14 wolf31o2 Exp $
+
+ 03 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ -files/quake3-1.34_alpha778-gfbsd.patch, -quake3-1.34_alpha778.ebuild,
+ quake3-1.34_alpha789.ebuild, quake3-9999.ebuild:
+ Added filter-flags to remove -mfpmath=sse for bug #149008.
*quake3-1.34_alpha789 (26 May 2006)
diff --git a/games-fps/quake3/quake3-1.34_alpha789.ebuild b/games-fps/quake3/quake3-1.34_alpha789.ebuild
index 7e54bbac0c8c..ff36e2f0575b 100644
--- a/games-fps/quake3/quake3-1.34_alpha789.ebuild
+++ b/games-fps/quake3/quake3-1.34_alpha789.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha789.ebuild,v 1.1 2006/05/26 01:00:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.34_alpha789.ebuild,v 1.2 2006/10/03 15:28:14 wolf31o2 Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -10,12 +10,12 @@
if [[ ${PV} == 9999* ]] ; then
[[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
- inherit subversion toolchain-funcs eutils games
+ inherit subversion flag-o-matic toolchain-funcs eutils games
SRC_URI=""
S=${WORKDIR}/trunk
elif [[ ${PV} == *_alpha* ]] ; then
- inherit toolchain-funcs eutils games
+ inherit flag-o-matic toolchain-funcs eutils games
MY_PV=${PV/_alpha*/}
SNAP=${PV/*_alpha/}
@@ -23,7 +23,7 @@ elif [[ ${PV} == *_alpha* ]] ; then
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
S=${WORKDIR}/${MY_P}
else
- inherit toolchain-funcs eutils games
+ inherit flag-o-matic toolchain-funcs eutils games
SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
fi
@@ -36,27 +36,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="dedicated opengl teamarena"
-RDEPEND="opengl? (
- virtual/opengl
+UIRDEPEND="virtual/opengl
media-libs/openal
- || (
- (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp )
- virtual/x11 )
- media-libs/libsdl )
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ media-libs/libsdl"
+
+RDEPEND="opengl? (
+ ${UIRDEPEND} )
!dedicated? (
- virtual/opengl
- || (
- (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp )
- virtual/x11 )
- media-libs/libsdl )
+ ${UIRDEPEND} )
games-fps/quake3-data
teamarena? ( games-fps/quake3-teamarena )"
@@ -70,6 +61,7 @@ src_unpack() {
}
src_compile() {
+ filter-flag -mfpmath=sse
buildit() { use $1 && echo 1 || echo 0 ; }
emake \
BUILD_SERVER=$(buildit dedicated) \
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
index ddddbfde2002..e57bffc03ea5 100644
--- a/games-fps/quake3/quake3-9999.ebuild
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.5 2006/05/23 22:04:19 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.6 2006/10/03 15:28:14 wolf31o2 Exp $
# quake3-9999 -> latest svn
# quake3-9999.REV -> use svn REV
@@ -8,22 +8,22 @@
# quake3-VER -> normal quake release
if [[ ${PV} == 9999* ]] ; then
- [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999.}"
+ [[ ${PV} == 9999.* ]] && ESVN_UPDATE_CMD="svn up -r ${PV/9999./}"
ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
- inherit subversion toolchain-funcs eutils games
+ inherit subversion flag-o-matic toolchain-funcs eutils games
SRC_URI=""
S=${WORKDIR}/trunk
elif [[ ${PV} == *_alpha* ]] ; then
- inherit toolchain-funcs eutils games
+ inherit flag-o-matic toolchain-funcs eutils games
- MY_PV=${PV/_alpha*}
- SNAP=${PV/*_alpha}
+ MY_PV=${PV/_alpha*/}
+ SNAP=${PV/*_alpha/}
MY_P=${PN}-${MY_PV}_SVN${SNAP}M
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
S=${WORKDIR}/${MY_P}
else
- inherit toolchain-funcs eutils games
+ inherit flag-o-matic toolchain-funcs eutils games
SRC_URI="http://icculus.org/quake3/${P}.tar.bz2"
fi
@@ -36,27 +36,18 @@ SLOT="0"
KEYWORDS="-*"
IUSE="dedicated opengl teamarena"
-RDEPEND="opengl? (
- virtual/opengl
+UIRDEPEND="virtual/opengl
media-libs/openal
- || (
- (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp )
- virtual/x11 )
- media-libs/libsdl )
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ media-libs/libsdl"
+
+RDEPEND="opengl? (
+ ${UIRDEPEND} )
!dedicated? (
- virtual/opengl
- || (
- (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp )
- virtual/x11 )
- media-libs/libsdl )
+ ${UIRDEPEND} )
games-fps/quake3-data
teamarena? ( games-fps/quake3-teamarena )"
@@ -65,10 +56,12 @@ src_unpack() {
subversion_src_unpack
else
unpack ${A}
+ cd "${S}"
fi
}
src_compile() {
+ filter-flag -mfpmath=sse
buildit() { use $1 && echo 1 || echo 0 ; }
emake \
BUILD_SERVER=$(buildit dedicated) \
@@ -87,14 +80,16 @@ src_install() {
cd code/unix
dodoc README.*
- doicon quake3.xpm
- make_desktop_entry quake3 "Quake III Arena" quake3.xpm
+ if use opengl ; then
+ doicon quake3.png
+ make_desktop_entry quake3 "Quake III Arena"
+ fi
cd ../../build/release*
local old_x x
- for old_x in ioquake3* ; do
+ for old_x in ioq* ; do
x=${old_x%.*}
- newgamesbin ${old_x} ${x} || die "dobin ${x}"
+ newgamesbin ${old_x} ${x} || die "newgamesbin ${x}"
dosym ${x} "${GAMES_BINDIR}"/${x/io}
done
exeinto "${GAMES_LIBDIR}"/${PN}/baseq3