summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-11-02 17:55:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-11-02 17:55:15 +0000
commit56b8aa73bb7082aea382e28ded948011c2cfff19 (patch)
tree1dc8f600c1e5d6a6ffe4ee41f1de8cd13ff60009 /games-mud/tintin/tintin-1.96.3.ebuild
parentAdded a patch to fix compilation problem in perl module for the first time. R... (diff)
downloadhistorical-56b8aa73bb7082aea382e28ded948011c2cfff19.tar.gz
historical-56b8aa73bb7082aea382e28ded948011c2cfff19.tar.bz2
historical-56b8aa73bb7082aea382e28ded948011c2cfff19.zip
version bump
Package-Manager: portage-2.1.2_pre3-r9
Diffstat (limited to 'games-mud/tintin/tintin-1.96.3.ebuild')
-rw-r--r--games-mud/tintin/tintin-1.96.3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-mud/tintin/tintin-1.96.3.ebuild b/games-mud/tintin/tintin-1.96.3.ebuild
new file mode 100644
index 000000000000..28d303d67b84
--- /dev/null
+++ b/games-mud/tintin/tintin-1.96.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tintin/tintin-1.96.3.ebuild,v 1.1 2006/11/02 17:55:15 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="(T)he k(I)cki(N) (T)ickin d(I)kumud clie(N)t"
+HOMEPAGE="http://www.scandum.com/tintin/"
+SRC_URI="mirror://sourceforge/tintin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib
+ sys-libs/readline
+ sys-libs/ncurses"
+
+S=${WORKDIR}/tt/src
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^MAKE/d' \
+ -e '/^CFLAGS/s/=/+=/' "${S}/Makefile.in" \
+ || die "sed failed"
+}
+
+src_install () {
+ dogamesbin tt++ || die "dogamesbin failed"
+ dodoc ../{BUGS,CREDITS,FAQ,README,TODO,docs/*}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "**** OLD TINTIN SCRIPTS ARE NOT 100% COMPATIBLE WITH THIS VERSION ****"
+ einfo "read the README for more details."
+ echo
+}