summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-03-21 20:27:32 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-03-21 20:27:32 +0000
commit635663d250494c6ad844f825c49500bedd45a17e (patch)
tree87ed112775f69ab28f6c2640af970b49f3c286fe /games-puzzle/gnudoku/gnudoku-0.93.ebuild
parentAdded development version of squirrelmail to package.mask. (diff)
downloadhistorical-635663d250494c6ad844f825c49500bedd45a17e.tar.gz
historical-635663d250494c6ad844f825c49500bedd45a17e.tar.bz2
historical-635663d250494c6ad844f825c49500bedd45a17e.zip
Version bump, bug #123726
Package-Manager: portage-2.1_pre6-r4
Diffstat (limited to 'games-puzzle/gnudoku/gnudoku-0.93.ebuild')
-rw-r--r--games-puzzle/gnudoku/gnudoku-0.93.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-puzzle/gnudoku/gnudoku-0.93.ebuild b/games-puzzle/gnudoku/gnudoku-0.93.ebuild
new file mode 100644
index 000000000000..b631d51d7507
--- /dev/null
+++ b/games-puzzle/gnudoku/gnudoku-0.93.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gnudoku/gnudoku-0.93.ebuild,v 1.1 2006/03/21 20:27:32 tupone Exp $
+
+inherit eutils games
+
+MY_PN="GNUDoku"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A program for creating and solving Su Doku puzzles"
+HOMEPAGE="http://www.icculus.org/~jcspray/GNUDoku"
+SRC_URI="http://www.icculus.org/~jcspray/GNUDoku/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-cpp/gtkmm-2.6"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dogamesbin GNUDoku || die "dogamesbin failed"
+ newicon GNUDoku.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+ prepgamesdirs
+}