summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 05:00:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 05:00:58 +0000
commit696c1f7b23ddcf3380afc75fc9a16d0bc088cf25 (patch)
treeac687054d6ed3ddb8881b3bfce63717172502b50 /games-puzzle/xblockout
parentdon't rdepend on sed (diff)
downloadhistorical-696c1f7b23ddcf3380afc75fc9a16d0bc088cf25.tar.gz
historical-696c1f7b23ddcf3380afc75fc9a16d0bc088cf25.tar.bz2
historical-696c1f7b23ddcf3380afc75fc9a16d0bc088cf25.zip
IUSE; don't rdepend on sed; tidy
Diffstat (limited to 'games-puzzle/xblockout')
-rw-r--r--games-puzzle/xblockout/ChangeLog7
-rw-r--r--games-puzzle/xblockout/Manifest6
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.2.ebuild19
3 files changed, 19 insertions, 13 deletions
diff --git a/games-puzzle/xblockout/ChangeLog b/games-puzzle/xblockout/ChangeLog
index 6c71440b3831..d7faf3caa5dd 100644
--- a/games-puzzle/xblockout/ChangeLog
+++ b/games-puzzle/xblockout/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/xblockout
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.3 2003/10/06 16:18:52 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.4 2004/03/24 05:00:58 mr_bones_ Exp $
+
+ 23 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> xblockout-1.1.2.ebuild:
+ IUSE; don't rdepend on sed; tidy
*xblockout-1.1.2 (06 Oct 2003)
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
index deb33a08afc4..0a668cd07539 100644
--- a/games-puzzle/xblockout/Manifest
+++ b/games-puzzle/xblockout/Manifest
@@ -1,4 +1,4 @@
-MD5 bc12081843bf725019a221ee79fe36ca ChangeLog 710
-MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 8be96c8d881e5d9be5c640ae3b8529ff xblockout-1.1.2.ebuild 1077
+MD5 6c5a2aa48a6f4607c6f2651968e2abf5 ChangeLog 828
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 2c032e8d2cb82533d33f030b24080175 xblockout-1.1.2.ebuild 1152
MD5 129edbcc1cd1677ce05bd1ba1dc1d85b files/digest-xblockout-1.1.2 61
diff --git a/games-puzzle/xblockout/xblockout-1.1.2.ebuild b/games-puzzle/xblockout/xblockout-1.1.2.ebuild
index 8f40ee57d11d..f5eb4328beaf 100644
--- a/games-puzzle/xblockout/xblockout-1.1.2.ebuild
+++ b/games-puzzle/xblockout/xblockout-1.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.2.ebuild,v 1.2 2004/02/20 06:53:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.2.ebuild,v 1.3 2004/03/24 05:00:58 mr_bones_ Exp $
inherit games
@@ -11,17 +11,20 @@ SRC_URI="ftp://ftp710.univ-lyon1.fr/pub/xbl/xbl-${PV}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
-DEPEND="virtual/x11
+RDEPEND="virtual/x11
+ virtual/glibc"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
-S=${WORKDIR}/xbl-${PV}
+S="${WORKDIR}/xbl-${PV}"
src_unpack() {
unpack ${A}
sed -i \
- -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in || \
- die "sed Makefile.in failed"
+ -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in \
+ || die "sed Makefile.in failed"
}
src_compile() {
@@ -29,12 +32,12 @@ src_compile() {
emake \
SCOREDIR=${GAMES_STATEDIR}/${PN} \
GROUP_GID=`id -g ${GAMES_GROUP}` \
- RESOURCEDIR=${GAMES_DATADIR}/${PN} || \
- die "emake failed"
+ RESOURCEDIR=${GAMES_DATADIR}/${PN} \
+ || die "emake failed"
}
src_install() {
- newgamesbin bl xbl
+ newgamesbin bl xbl || die "newgamesbin failed"
insinto ${GAMES_DATADIR}/${PN}
newins Xbl.ad Xbl
insinto ${GAMES_STATEDIR}/${PN}