summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 19:03:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-21 19:03:10 +0000
commitd52840d4e3c692bcf9b764fdb1443ebb9a3cdf53 (patch)
treef0b25563642d4d56efafbd69ddcf20fda631472c /games-puzzle
parentthis commitmsg brought to you by the 'bumpage is a word' society (diff)
downloadhistorical-d52840d4e3c692bcf9b764fdb1443ebb9a3cdf53.tar.gz
historical-d52840d4e3c692bcf9b764fdb1443ebb9a3cdf53.tar.bz2
historical-d52840d4e3c692bcf9b764fdb1443ebb9a3cdf53.zip
python 2.2 fix for bug #48521
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/kiki/ChangeLog8
-rw-r--r--games-puzzle/kiki/Manifest6
-rw-r--r--games-puzzle/kiki/kiki-0.9.0.ebuild5
3 files changed, 12 insertions, 7 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index 0644c4f12ee3..82d0b83fb42c 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/kiki
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.2 2003/09/10 15:46:09 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.3 2004/04/21 19:03:10 mr_bones_ Exp $
+
+ 21 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> kiki-0.9.0.ebuild:
+ source has hard-coded python 2.2 stuff. Didn't work with python 2.3.3 either
+ so locking it into 2.2 for now. Patches welcome. (bug #48521)
*kiki-0.9.0 (05 Aug 2003)
diff --git a/games-puzzle/kiki/Manifest b/games-puzzle/kiki/Manifest
index 905f4f58b1b3..0082e128815b 100644
--- a/games-puzzle/kiki/Manifest
+++ b/games-puzzle/kiki/Manifest
@@ -1,4 +1,4 @@
-MD5 9721438ad8f7d2ff3cadd7c82d71eb94 files/digest-kiki-0.9.0 64
-MD5 74d0bb7d5d36e0303170b25b14e42be6 ChangeLog 393
-MD5 a261b749e8baaeac362f7ad8d89bf778 kiki-0.9.0.ebuild 1662
+MD5 0b4be5a07d7918d06c04370fe6e9d1e5 ChangeLog 616
+MD5 a99403f0a73f9790aadaaa283f924e32 kiki-0.9.0.ebuild 1698
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 9721438ad8f7d2ff3cadd7c82d71eb94 files/digest-kiki-0.9.0 64
diff --git a/games-puzzle/kiki/kiki-0.9.0.ebuild b/games-puzzle/kiki/kiki-0.9.0.ebuild
index 11bd9b631a4a..c46c97b0c7e6 100644
--- a/games-puzzle/kiki/kiki-0.9.0.ebuild
+++ b/games-puzzle/kiki/kiki-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-0.9.0.ebuild,v 1.2 2004/02/20 06:53:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-0.9.0.ebuild,v 1.3 2004/04/21 19:03:10 mr_bones_ Exp $
inherit games
@@ -18,7 +18,7 @@ IUSE=""
RDEPEND=">=media-libs/libsdl-1.2
>=media-libs/sdl-image-1.2.2
>=media-libs/sdl-mixer-1.2.5
- >=dev-lang/python-2.2
+ =dev-lang/python-2.2*
virtual/glut"
DEPEND="${RDEPEND}
>=sys-devel/gcc-3
@@ -31,6 +31,7 @@ src_unpack() {
# There are CVS directories in the tgz file
rm -rf `find -name CVS -type d`
rm -rf `find -name .cvsignore`
+ chmod a-x kiki_src/kiki/sounds/*.*
# Change the hard-coded data dir for sounds, etc...
sed -i \