summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 04:59:58 +0000
commit0bb76cbaabcb2e024867417795e8c6b19786b020 (patch)
tree2a0f2a2466549809e3b960bb8cde4777773230e0 /games-roguelike/crossfire-client
parentrepoman: fix leading whitespace (diff)
downloadhistorical-0bb76cbaabcb2e024867417795e8c6b19786b020.tar.gz
historical-0bb76cbaabcb2e024867417795e8c6b19786b020.tar.bz2
historical-0bb76cbaabcb2e024867417795e8c6b19786b020.zip
hello rogues
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog31
-rw-r--r--games-roguelike/crossfire-client/Manifest4
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.5.0.ebuild50
-rw-r--r--games-roguelike/crossfire-client/files/1.5.0-errno.patch21
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.5.01
5 files changed, 107 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
new file mode 100644
index 000000000000..5d917fbda063
--- /dev/null
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -0,0 +1,31 @@
+# ChangeLog for app-games/crossfire-client
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+
+*crossfire-client-1.5.0 (27 Jun 2003)
+
+ 03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Disable alsa if using newer version #25743.
+
+ 27 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #22201 + games.eclass support + errno patch.
+ Also reworked optional stuff.
+
+*crossfire-client-1.4.0 (22 Nov 2002)
+
+ 12 Jun 2003; Seemant Kulleen <seemant@gentoo.org>
+ crossfire-client-1.2.1.ebuild, crossfire-client-1.4.0.ebuild:
+ xfree provides xpm
+
+ 22 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Version bump for 10810 and general cleanups
+
+*crossfire-client-1.2.1 (09 May 2002)
+
+ 23 Sep 2002; Mike Frysinger <vapier@gentoo.org> :
+ Updated SRC_URI to use mirror: and LICENSE to GPL-2
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> crossfire-client-1.2.1.ebuild :
+ Added KEYWORDS, SLOT.
+
+ 09 May 2002; J. Alberto Suárez L. <bass@gentoo.org> crossfire-client-1.2.1.ebuild:
+ Added the Crossfire-client to portage.
diff --git a/games-roguelike/crossfire-client/Manifest b/games-roguelike/crossfire-client/Manifest
new file mode 100644
index 000000000000..87280c7b0f36
--- /dev/null
+++ b/games-roguelike/crossfire-client/Manifest
@@ -0,0 +1,4 @@
+MD5 d8e0b6aeda4e4938606822e33edf7322 files/digest-crossfire-client-1.5.0 74
+MD5 ad1e49c4a56222488166b9c4f4091a55 files/1.5.0-errno.patch 682
+MD5 a3add6a20959912624ecefb98814b94d crossfire-client-1.5.0.ebuild 1441
+MD5 c86775e8d8951d96331c9ff01f9191d6 ChangeLog 1069
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.5.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.5.0.ebuild
new file mode 100644
index 000000000000..8a613722139a
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.5.0.ebuild,v 1.1 2003/09/10 04:59:58 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="sdl gnome gtk alsa"
+
+DEPEND="virtual/x11
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image )
+ gnome? ( gnome-base/gnome-libs
+ media-libs/gdk-pixbuf )
+ gtk? ( =x11-libs/gtk+-1* )
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libpng"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+}
+
+src_compile() {
+ # bugs in configure script so we cant use `use_enable`
+ local myconf=""
+ use gtk || myconf="${myconf} --disable-gtk"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa"
+ has_version '>=media-libs/alsa-lib-0.9' && myconf="${myconf} --disable-alsa"
+ use gnome || myconf="${myconf} --disable-gnome"
+ egamesconf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ egamesinstall mandir=${T} || die
+ use gtk && newman gtk/gcfclient.man gcfclient.6
+ use gnome && newman gnome/gnome-cfclient.man gnome-cfclient.6
+ newman x11/cfclient.man cfclient.6
+ dodoc CHANGES NOTES README TODO
+ prepgamesdirs
+}
diff --git a/games-roguelike/crossfire-client/files/1.5.0-errno.patch b/games-roguelike/crossfire-client/files/1.5.0-errno.patch
new file mode 100644
index 000000000000..c0c929b40bce
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/1.5.0-errno.patch
@@ -0,0 +1,21 @@
+--- common/client.h.orig 2003-06-27 20:15:48.000000000 -0400
++++ common/client.h 2003-06-27 20:16:12.000000000 -0400
+@@ -270,7 +270,7 @@
+ /* We need to declare most of the structs before we can include this */
+ #include <proto.h>
+
+-extern int errno;
++#include <errno.h>
+
+ /* translation of the STAT_RES names into printable names,
+ * in matching order.
+--- common/newsocket.c.orig 2003-06-27 20:15:36.000000000 -0400
++++ common/newsocket.c 2003-06-27 20:15:41.000000000 -0400
+@@ -154,7 +154,6 @@
+ int SockList_ReadPacket(int fd, SockList *sl, int len)
+ {
+ int stat,toread,readsome=0;
+- extern int errno;
+
+ /* We already have a partial packet */
+ if (sl->len<2) {
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.5.0 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.5.0
new file mode 100644
index 000000000000..adaab6c435c3
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.5.0
@@ -0,0 +1 @@
+MD5 8f7e09f18cdbfbf45aea2fc06a6472cb crossfire-client-1.5.0.tar.gz 405044