summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-25 09:48:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-25 09:48:18 +0000
commitce333165cfd3c52456b59e9c914018231335054a (patch)
tree46b002f9599d882db1f63e758324ffcb9be07017 /games-roguelike/crossfire-client
parentold (diff)
downloadhistorical-ce333165cfd3c52456b59e9c914018231335054a.tar.gz
historical-ce333165cfd3c52456b59e9c914018231335054a.tar.bz2
historical-ce333165cfd3c52456b59e9c914018231335054a.zip
ver bump
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog5
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.6.0.ebuild50
-rw-r--r--games-roguelike/crossfire-client/files/1.6.0-errno.patch21
-rw-r--r--games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.01
4 files changed, 77 insertions, 0 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 8fbbed0c5b90..9da28e95fa21 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+*crossfire-client-1.6.0 (25 Oct 2003)
+
+ 25 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
*crossfire-client-1.5.0 (27 Jun 2003)
03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.6.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.6.0.ebuild
new file mode 100644
index 000000000000..e0a35249e723
--- /dev/null
+++ b/games-roguelike/crossfire-client/crossfire-client-1.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.6.0.ebuild,v 1.1 2003/10/25 09:48:18 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Client for the nethack-style but more in the line of UO"
+HOMEPAGE="http://crossfire.real-time.com/"
+SRC_URI="mirror://sourceforge/crossfire/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="sdl gnome gtk alsa"
+
+DEPEND="virtual/x11
+ sdl? ( media-libs/libsdl
+ media-libs/sdl-image )
+ gnome? ( gnome-base/gnome-libs
+ media-libs/gdk-pixbuf )
+ gtk? ( =x11-libs/gtk+-1* )
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libpng"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+}
+
+src_compile() {
+ # bugs in configure script so we cant use `use_enable`
+ local myconf=""
+ use gtk || myconf="${myconf} --disable-gtk"
+ use sdl || myconf="${myconf} --disable-sdl"
+ use alsa || myconf="${myconf} --disable-alsa"
+ has_version '>=media-libs/alsa-lib-0.9' && myconf="${myconf} --disable-alsa --disable-sound"
+ use gnome || myconf="${myconf} --disable-gnome"
+ egamesconf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ egamesinstall mandir=${T} || die
+ use gtk && newman gtk/gcfclient.man gcfclient.6
+ use gnome && newman gnome/gnome-cfclient.man gnome-cfclient.6
+ newman x11/cfclient.man cfclient.6
+ dodoc CHANGES NOTES README TODO
+ prepgamesdirs
+}
diff --git a/games-roguelike/crossfire-client/files/1.6.0-errno.patch b/games-roguelike/crossfire-client/files/1.6.0-errno.patch
new file mode 100644
index 000000000000..c0c929b40bce
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/1.6.0-errno.patch
@@ -0,0 +1,21 @@
+--- common/client.h.orig 2003-06-27 20:15:48.000000000 -0400
++++ common/client.h 2003-06-27 20:16:12.000000000 -0400
+@@ -270,7 +270,7 @@
+ /* We need to declare most of the structs before we can include this */
+ #include <proto.h>
+
+-extern int errno;
++#include <errno.h>
+
+ /* translation of the STAT_RES names into printable names,
+ * in matching order.
+--- common/newsocket.c.orig 2003-06-27 20:15:36.000000000 -0400
++++ common/newsocket.c 2003-06-27 20:15:41.000000000 -0400
+@@ -154,7 +154,6 @@
+ int SockList_ReadPacket(int fd, SockList *sl, int len)
+ {
+ int stat,toread,readsome=0;
+- extern int errno;
+
+ /* We already have a partial packet */
+ if (sl->len<2) {
diff --git a/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.0 b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.0
new file mode 100644
index 000000000000..9b29f8652162
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/digest-crossfire-client-1.6.0
@@ -0,0 +1 @@
+MD5 90f46a9f74ab0d2b82ccfb2812e5d6cf crossfire-client-1.6.0.tar.gz 421159