summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-05-29 21:19:42 +0000
committerTristan Heaven <tristan@gentoo.org>2007-05-29 21:19:42 +0000
commitc3d5986ac32d9cdf2fd3b14361ce5698a71eeffa (patch)
tree8e6813f47798b15d1c4444db5c3565926041bdd7 /games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild
parentRemoved obsolete patch, fixes bug 179653. (diff)
downloadhistorical-c3d5986ac32d9cdf2fd3b14361ce5698a71eeffa.tar.gz
historical-c3d5986ac32d9cdf2fd3b14361ce5698a71eeffa.tar.bz2
historical-c3d5986ac32d9cdf2fd3b14361ce5698a71eeffa.zip
Version bump
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild')
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild b/games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild
new file mode 100644
index 000000000000..357f6d532221
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.9.7.ebuild,v 1.1 2007/05/29 21:19:42 nyhm Exp $
+
+inherit eutils games
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+
+S=${WORKDIR}/${MY_P}/make/linux
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:updater::' \
+ -e '/\/tools/d' \
+ Makefile.in \
+ || die "sed failed"
+ chmod +x configure
+}
+
+src_compile() {
+ egamesconf --disable-simplelayout || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd ../..
+ dodoc README*
+ newicon bitmaps/pentagram.png ${PN}.png
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}