summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-16 19:52:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-16 19:52:58 +0000
commit4385cd7b76c26dbee9c57dad2b93d1a436fa6350 (patch)
tree7f6cf058873c8f0651a315f857e24968b5564f87 /games-simulation
parentFix CVS Header. (diff)
downloadhistorical-4385cd7b76c26dbee9c57dad2b93d1a436fa6350.tar.gz
historical-4385cd7b76c26dbee9c57dad2b93d1a436fa6350.tar.bz2
historical-4385cd7b76c26dbee9c57dad2b93d1a436fa6350.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/Manifest4
-rw-r--r--games-simulation/openttd/openttd-1.0.4.ebuild169
3 files changed, 179 insertions, 2 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 7a11734496df..a4d683ec1c85 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.98 2010/08/14 21:38:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.99 2010/09/16 19:52:58 mr_bones_ Exp $
+
+*openttd-1.0.4 (16 Sep 2010)
+
+ 16 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +openttd-1.0.4.ebuild:
+ version bump
14 Aug 2010; Michael Sterrett <mr_bones_@gentoo.org> openttd-1.0.3.ebuild:
dedicated server needs some media as well (bug #332675)
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index a276f2d33ceb..a3c0ff211dd5 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,5 +1,7 @@
AUX openttd.initd 529 RMD160 ff9fdf7a787ae3d08ec4dbef1b1b37eee12d1ccd SHA1 f833206fc430c6e7afec76c39e97af0f7ec6578a SHA256 a16e5c64a073d0b7e7092bb906b7f064414870a8607bebce16b4b08cff7f4112
DIST openttd-1.0.3-source.tar.bz2 5395672 RMD160 cf0bfae7384c965a755cf695755b350436991964 SHA1 0a9c726d484288df388067ceed114c52fb0682d6 SHA256 f52f2381c678de024d26ee465c8203323eb3484300c4dc182c0d68c439ee8c57
+DIST openttd-1.0.4-source.tar.bz2 5684460 RMD160 1f5d585bddfdb4ec649a81ad9317caeb1c69cb24 SHA1 7289f7d8236a65d959d153a5209d4686ebc8de8c SHA256 2c6b1c314f6d5e2d72543cad78769d47837d59b69c98c4356d0076498db6426c
EBUILD openttd-1.0.3.ebuild 5135 RMD160 27415ec44a73c4e17485e6b403640b8732c54837 SHA1 d2994b2a0857a3e6ecce6aa29acafca8fc13fe5f SHA256 d7bc97926021cdcf7882b0c0dbd047453fdc85f4b39963b0baab7b0fcb6608d0
-MISC ChangeLog 12879 RMD160 7e577061d6ac48a70b204cab8ba75a2535d84542 SHA1 55f6ccb9e64d0af63e5a98e46bd8a2861d342934 SHA256 0680781eff496eee87f4d81b27624cf055d7df952a0f7235819597c878948a06
+EBUILD openttd-1.0.4.ebuild 5139 RMD160 9a6fd1f05b5af76cb4d4de9baca2d6081c3fd5fb SHA1 927505fb3006ad36bacc9fc7a55210c33f900002 SHA256 6a98323f5f8978667f6b6567b366ad9add43ca926c7486eb7d6aa8b2069f0179
+MISC ChangeLog 13005 RMD160 29c26499d92df74c8147e33fcc40efc96fa80c78 SHA1 041cfb4ed1dbc4e376c63c7a32e0a668903f5e36 SHA256 727ef0e20013d9625fbfcfe756a1e0dd6a440b05b51f8aba4df2b5579873fff3
MISC metadata.xml 658 RMD160 3e5f41ef03cfc2b3d91f3fe18939ded3aaf86cd1 SHA1 e5b0eefc09ca65a2dd09049aca0da1b6dcbe269c SHA256 d0e2ff0d4bbe57e15d58e5fc68884b70877561f127e8afd7b5ce3e4a46e97404
diff --git a/games-simulation/openttd/openttd-1.0.4.ebuild b/games-simulation/openttd/openttd-1.0.4.ebuild
new file mode 100644
index 000000000000..f60c7f0d2c90
--- /dev/null
+++ b/games-simulation/openttd/openttd-1.0.4.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.0.4.ebuild,v 1.1 2010/09/16 19:52:58 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_PV=${PV/_rc/-RC}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.org/"
+SRC_URI="http://binaries.openttd.org/releases/${MY_PV}/${MY_P}-source.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png +timidity +truetype zlib"
+
+DEPEND="
+ !dedicated? (
+ media-libs/libsdl[audio,X,video]
+ icu? ( dev-libs/icu )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-libs/zlib
+ )
+ )
+ lzo? ( dev-libs/lzo:2 )
+ iconv? ( virtual/libiconv )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+
+PDEPEND="
+ !dedicated? (
+ openmedia? (
+ games-misc/openmsx
+ games-misc/opensfx
+ )
+ aplaymidi? ( media-sound/alsa-utils )
+ !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
+ )
+ openmedia? ( games-misc/opengfx )
+ "
+
+src_configure() {
+ # there is an allegro interface available as well as sdl, but
+ # the configure for it looks broken so the sdl interface is
+ # always built instead.
+ local myopts="${myopts} --without-allegro"
+
+ # libtimidity not needed except for some embedded platform
+ # nevertheless, it will be automagically linked if it is
+ # installed. Hence, we disable it.
+ myopts="${myopts} --without-libtimidity"
+
+ use debug && myopts="${myopts} --enable-debug=3"
+
+ if use dedicated ; then
+ myopts="${myopts} --enable-dedicated"
+ else
+ use aplaymidi && myopts="${myopts} --with-midi='/usr/bin/aplaymidi'"
+ myopts="${myopts}
+ $(use_with truetype freetype)
+ $(use_with icu)
+ --with-sdl"
+ fi
+ if use png || { use !dedicated && use truetype; } || use zlib ; then
+ myopts="${myopts} --with-zlib"
+ else
+ myopts="${myopts} --without-zlib"
+ fi
+
+ # configure is a hand-written bash-script, so econf will not work.
+ # It's all built as C++, upstream uses CFLAGS internally.
+ CFLAGS="" ./configure \
+ --disable-strip \
+ --prefix-dir="${EPREFIX}" \
+ --binary-dir="${GAMES_BINDIR}" \
+ --data-dir="${GAMES_DATADIR}/${PN}" \
+ --install-dir="${D}" \
+ --icon-dir=/usr/share/pixmaps \
+ --menu-dir=/usr/share/applications \
+ --icon-theme-dir=/usr/share/icons/hicolor \
+ --man-dir=/usr/share/man/man6 \
+ --doc-dir=/usr/share/doc/${PF} \
+ --menu-group="Game;Simulation;" \
+ ${myopts} \
+ $(use_with iconv) \
+ $(use_with png) \
+ $(use_with lzo liblzo2) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake VERBOSE=1 || die
+}
+
+src_test() {
+ vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ emake -j1 test || die "Make test failed. See above for details."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use dedicated ; then
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm -rf "${D}"/usr/share/{applications,icons,pixmaps}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+ prepalldocs
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use lzo ; then
+ elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
+ elog "required, disabling it does mean that loading old savegames"
+ elog "or scenarios from ancient versions (~0.2) will fail."
+ elog
+ fi
+
+ if use dedicated ; then
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when triggered, including any running client sessions!"
+ else
+ if use aplaymidi ; then
+ elog "You have emerged with 'aplaymidi' for playing MIDI."
+ elog "This option is for those with a hardware midi device,"
+ elog "or who have set up ALSA to handle midi ports."
+ elog "You must set the environment variable ALSA_OUTPUT_PORTS."
+ elog "Available ports can be listed by using 'aplaymidi -l'."
+ else
+ if ! use timidity ; then
+ elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
+ elog "in USE. Music may or may not work in-game. If you happen"
+ elog "to have timidity++ installed, music will work so long"
+ elog "as it remains installed, but OpenTTD will not depend on it."
+ fi
+ fi
+ if ! use openmedia ; then
+ elog
+ elog "OpenTTD was compiled without the 'openmedia' USE flag."
+ elog
+ elog "In order to play, you must at least install:"
+ elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
+ elog "following 6 files from a version of Transport Tycoon Deluxe"
+ elog "(windows or DOS) to ~/.openttd/data/ or"
+ elog "${GAMES_DATADIR}/${PN}/data/."
+ elog
+ elog "From the WINDOWS version you need: "
+ elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ elog "OR from the DOS version you need: "
+ elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ elog
+ elog "File names are case sensitive, but should work either with"
+ elog "all upper or all lower case names"
+ elog
+ elog "In addition, in-game music will be unavailable: for music,"
+ elog "install games-misc/openmsx, or use the in-game download"
+ elog "functionality to get a music set"
+ elog
+ fi
+ fi
+}