summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-06-03 05:36:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-06-03 05:36:12 +0000
commitcc964fb40e8138c09a7197384f57f7b44c056c3b (patch)
treebc7f78f411f8e9a74450f3356eee93e58752a237 /games-strategy/attal/attal-0.9.3.ebuild
parentMarked ppc stable. (diff)
downloadhistorical-cc964fb40e8138c09a7197384f57f7b44c056c3b.tar.gz
historical-cc964fb40e8138c09a7197384f57f7b44c056c3b.tar.bz2
historical-cc964fb40e8138c09a7197384f57f7b44c056c3b.zip
version bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-strategy/attal/attal-0.9.3.ebuild')
-rw-r--r--games-strategy/attal/attal-0.9.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-strategy/attal/attal-0.9.3.ebuild b/games-strategy/attal/attal-0.9.3.ebuild
new file mode 100644
index 000000000000..d6fe5333202e
--- /dev/null
+++ b/games-strategy/attal/attal-0.9.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.9.3.ebuild,v 1.1 2005/06/03 05:36:12 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="turn-based strategy game project"
+HOMEPAGE="http://www.attal-thegame.org/"
+SRC_URI="mirror://sourceforge/attal/${MY_P}.tar.bz2
+ mirror://sourceforge/attal/themes-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3*"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:\"\./:\"${GAMES_BINDIR}/:" \
+ server/serverInterface.cpp \
+ client/clientInterface.cpp \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"\./:\"${GAMES_DATADIR}/${PN}/:" \
+ libCommon/displayHelp.cpp \
+ || die "sed failed"
+ qmake -o Makefile Makefile.pro || die "qmake failed"
+ sed -i \
+ "s:\./themes/:${GAMES_DATADIR}/${PN}/themes/:" \
+ `grep -Rl '\./themes/' *` \
+ || die "fixing theme loc"
+ find "${WORKDIR}"/themes-${PV} -name .cvsignore -print0 | xargs -0 rm -f
+}
+
+src_compile() {
+ # broken deps in the makefiles ...
+ append-flags -fPIC
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ sub-libCommon || die "emake sub-libCommon failed"
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ sub-{libFight,libClient,libServer} || die "emake libs failed"
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin attal-* || die "dogamesbin failed"
+ into "${GAMES_PREFIX}"
+ dolib.so lib*.so* || die "dolib.so failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins HOWTOPLAY.html
+ insinto "${GAMES_DATADIR}"/${PN}/themes
+ doins -r "${WORKDIR}"/themes-${PV}/* || die "doins themes failed"
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}