summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-05-05 02:49:53 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-05-05 02:49:53 +0000
commit1bed54429aedb49e23628af9cca8b10202b89351 (patch)
tree691aca718f7c29808956a33d0be199b683ff1be1 /games-strategy/widelands
parentBump. (diff)
downloadhistorical-1bed54429aedb49e23628af9cca8b10202b89351.tar.gz
historical-1bed54429aedb49e23628af9cca8b10202b89351.tar.bz2
historical-1bed54429aedb49e23628af9cca8b10202b89351.zip
Initial import. Original ebuild by Elias Kunnas <elias_kunnas@welho.com>. Ebuild modified by Christoph Brill <egore@gmx.de> and by myself. Original amd64 patch idea by Peter Roozemaal <mathfox@xs4all.nl>. Closing bug #59674.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/ChangeLog13
-rw-r--r--games-strategy/widelands/files/digest-widelands-0.0.91
-rw-r--r--games-strategy/widelands/files/widelands-0.0.9-amd64.patch14
-rw-r--r--games-strategy/widelands/metadata.xml5
-rw-r--r--games-strategy/widelands/widelands-0.0.9.ebuild48
5 files changed, 81 insertions, 0 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
new file mode 100644
index 000000000000..4f4b05d12a1e
--- /dev/null
+++ b/games-strategy/widelands/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for games-strategy/widelands
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.1 2005/05/05 02:49:53 wolf31o2 Exp $
+
+*widelands-0.0.9 (05 May 2005)
+
+ 05 May 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/widelands-0.0.9-amd64.patch, +metadata.xml,
+ +widelands-0.0.9.ebuild:
+ Initial import. Original ebuild by Elias Kunnas <elias_kunnas@welho.com>.
+ Ebuild modified by Christoph Brill <egore@gmx.de> and by myself. Original
+ amd64 patch idea by Peter Roozemaal <mathfox@xs4all.nl>. Closing bug #59674.
+
diff --git a/games-strategy/widelands/files/digest-widelands-0.0.9 b/games-strategy/widelands/files/digest-widelands-0.0.9
new file mode 100644
index 000000000000..a693c7d6ba99
--- /dev/null
+++ b/games-strategy/widelands/files/digest-widelands-0.0.9
@@ -0,0 +1 @@
+MD5 0efaa379795496c05feee47de27b5dae widelands-b9-source.tar.bz2 2135320
diff --git a/games-strategy/widelands/files/widelands-0.0.9-amd64.patch b/games-strategy/widelands/files/widelands-0.0.9-amd64.patch
new file mode 100644
index 000000000000..c29031497be9
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.0.9-amd64.patch
@@ -0,0 +1,14 @@
+diff -urN widelands.orig/src/machdep.h widelands/src/machdep.h
+--- widelands.orig/src/machdep.h 2005-05-04 22:31:16.000000000 -0400
++++ widelands/src/machdep.h 2005-05-04 22:31:37.000000000 -0400
+@@ -36,6 +36,10 @@
+ #undef P_BIG_ENDIAN
+ #define P_LITTLE_ENDIAN
+ #undef P_ALIGNMENT
++#elif defined (__x86_64__)
++#undef P_BIG_ENDIAN
++#define P_LITTLE_ENDIAN
++#undef P_ALIGNMENT
+ #else
+ #error architecture not supported
+ #endif
diff --git a/games-strategy/widelands/metadata.xml b/games-strategy/widelands/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/widelands/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/widelands/widelands-0.0.9.ebuild b/games-strategy/widelands/widelands-0.0.9.ebuild
new file mode 100644
index 000000000000..c97849612807
--- /dev/null
+++ b/games-strategy/widelands/widelands-0.0.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.9.ebuild,v 1.1 2005/05/05 02:49:53 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="A game similar to Settlers 2"
+HOMEPAGE="http://widelands.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-b${PV:4:4}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug"
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ sys-libs/zlib
+ media-libs/jpeg
+ media-libs/libpng"
+
+S="${WORKDIR}/${PN}"
+dir="${GAMES_DATADIR}/${PN}"
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-amd64.patch || die
+}
+
+src_compile() {
+ use debug || export BUILD="release"
+ emake || die "emake failed"
+ unset BUILD
+}
+
+src_install() {
+ dodir ${dir}
+ insinto ${dir}
+ exeinto ${dir}
+ doins -r fonts maps pics tribes worlds campaigns README COPYING \
+ || die "copying data files"
+ doexe ${PN} || die "copying widelands"
+ games_make_wrapper widelands ./widelands ${dir}
+ dodoc AUTHORS COPYING ChangeLog README
+ prepgamesdirs
+}