summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-10-18 00:53:37 +0000
committerTristan Heaven <tristan@gentoo.org>2006-10-18 00:53:37 +0000
commite8a4738cdedae03d62eff9ae56034b2659e6cb54 (patch)
tree12ce8e681eb66af7dac7b3bf2fc6ae69e01d105a /games-strategy
parentPruned old revisions. (diff)
downloadhistorical-e8a4738cdedae03d62eff9ae56034b2659e6cb54.tar.gz
historical-e8a4738cdedae03d62eff9ae56034b2659e6cb54.tar.bz2
historical-e8a4738cdedae03d62eff9ae56034b2659e6cb54.zip
Version bump, bug #118592
Package-Manager: portage-2.1.2_pre3-r3
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/triplea/ChangeLog7
-rw-r--r--games-strategy/triplea/files/digest-triplea-0.8.2.13
-rw-r--r--games-strategy/triplea/triplea-0.8.2.1.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index ef65be70a094..4a517f8f7123 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/triplea
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.21 2006/01/27 19:32:23 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.22 2006/10/18 00:53:37 nyhm Exp $
+
+*triplea-0.8.2.1 (18 Oct 2006)
+
+ 18 Oct 2006; Tristan Heaven <nyhm@gentoo.org> +triplea-0.8.2.1.ebuild:
+ Version bump, bug #118592
27 Jan 2006; Michael Hanselmann <hansmi@gentoo.org>
triplea-0.6.0.1.ebuild:
diff --git a/games-strategy/triplea/files/digest-triplea-0.8.2.1 b/games-strategy/triplea/files/digest-triplea-0.8.2.1
new file mode 100644
index 000000000000..3c2362e3b18b
--- /dev/null
+++ b/games-strategy/triplea/files/digest-triplea-0.8.2.1
@@ -0,0 +1,3 @@
+MD5 bb62b18f801d2afecd51d9cbaa6ddb3f triplea_0_8_2_1_source_code_only.zip 9721814
+RMD160 36b8462472da92c46b505a55ff31e426f377e48c triplea_0_8_2_1_source_code_only.zip 9721814
+SHA256 da5c45a4ddc432685ea0b87b17b71a55318a38880668bf2316455ca655556dd0 triplea_0_8_2_1_source_code_only.zip 9721814
diff --git a/games-strategy/triplea/triplea-0.8.2.1.ebuild b/games-strategy/triplea/triplea-0.8.2.1.ebuild
new file mode 100644
index 000000000000..31d37965777c
--- /dev/null
+++ b/games-strategy/triplea/triplea-0.8.2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.8.2.1.ebuild,v 1.1 2006/10/18 00:53:37 nyhm Exp $
+
+inherit eutils java-ant-2 java-pkg-2 versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="An open source clone of the popular Axis and Allies boardgame"
+HOMEPAGE="http://triplea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_PV}_source_code_only.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5
+ =dev-java/jgoodies-looks-1.3*"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ dev-java/ant
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}_${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/lib
+
+ rm *.jar
+ java-pkg_jar-from jgoodies-looks-1.3 looks.jar looks-1.3.1.jar
+}
+
+src_compile() {
+ eant || die
+}
+
+src_install() {
+ games_make_wrapper ${PN} \
+ 'java -cp classes:$(java-config -p jgoodies-looks-1.3) \
+ games.strategy.engine.framework.GameRunner' \
+ "${GAMES_DATADIR}"/${PN}
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r classes data games images maps || die "doins failed"
+
+ newicon icons/triplea_icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} TripleA /usr/share/pixmaps/${PN}.bmp
+
+ dodoc changelog.txt
+ dohtml -r doc/* readme.html
+ prepgamesdirs
+}