summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 17:25:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-07 17:25:01 +0000
commitd44e57cc0027dcae1078dbf5e5c823a014ecf637 (patch)
tree6e1c8b56978e495494ff359db136941b8842cda4 /games-util
parentPrint elog only if USE=suid, bug #312841, thank Martin von Gagern for report. (diff)
downloadhistorical-d44e57cc0027dcae1078dbf5e5c823a014ecf637.tar.gz
historical-d44e57cc0027dcae1078dbf5e5c823a014ecf637.tar.bz2
historical-d44e57cc0027dcae1078dbf5e5c823a014ecf637.zip
initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko via bug #308355
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'games-util')
-rw-r--r--games-util/catcodec/ChangeLog11
-rw-r--r--games-util/catcodec/Manifest5
-rw-r--r--games-util/catcodec/catcodec-1.0.0.ebuild25
-rw-r--r--games-util/catcodec/files/catcodec-1.0.0-build.patch26
-rw-r--r--games-util/catcodec/metadata.xml5
5 files changed, 72 insertions, 0 deletions
diff --git a/games-util/catcodec/ChangeLog b/games-util/catcodec/ChangeLog
new file mode 100644
index 000000000000..14043c94d45a
--- /dev/null
+++ b/games-util/catcodec/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-util/catcodec
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/ChangeLog,v 1.1 2010/04/07 17:25:01 mr_bones_ Exp $
+
+*catcodec-1.0.0 (07 Apr 2010)
+
+ 07 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +catcodec-1.0.0.ebuild, +files/catcodec-1.0.0-build.patch:
+ initial commit - ebuild submitted by Locke 'Wizzleby' Shinseiko via bug
+ #308355
+
diff --git a/games-util/catcodec/Manifest b/games-util/catcodec/Manifest
new file mode 100644
index 000000000000..cf655062683c
--- /dev/null
+++ b/games-util/catcodec/Manifest
@@ -0,0 +1,5 @@
+AUX catcodec-1.0.0-build.patch 823 RMD160 1ca9bf536b7d0fc85181a43e65ef395c61b5c445 SHA1 3480a238c6398deb353dd5d8c546db5011482016 SHA256 5063c6b925c581e500a647855f2b03079957869bf2b09e1d2d16b69ddc590fae
+DIST catcodec-1.0.0-source.tar.bz2 17858 RMD160 01c88adb05867aca0e290c62981dd866f0fe454c SHA1 058e17c6e88586f54a262a34a1a12f4f188a8d31 SHA256 4396da1a0f51451f663dcb406250bc599a1f376016d286ffe48c3591e964f46d
+EBUILD catcodec-1.0.0.ebuild 656 RMD160 bc487552c7b4785f66db7a96b0c549c070360a5e SHA1 fa6365b3b0fb8a0fc45463dbcbf52785ddea0245 SHA256 fddb257b42cb5f740bd9fab8dbe251ec6b5acf5e52fe38c2a236e3d5f272e712
+MISC ChangeLog 446 RMD160 9ed230b2a9eab8511349bcd19bd73c4d0db76716 SHA1 9f1eed592619a81fbade27c45cd64a8df99b80a9 SHA256 c343596ce13418311dc497ec3532f92f45446c19b561dd40262d5cdb7d9c6770
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-util/catcodec/catcodec-1.0.0.ebuild b/games-util/catcodec/catcodec-1.0.0.ebuild
new file mode 100644
index 000000000000..47383afc5f71
--- /dev/null
+++ b/games-util/catcodec/catcodec-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/catcodec/catcodec-1.0.0.ebuild,v 1.1 2010/04/07 17:25:01 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Decodes and encodes sample catalogues for OpenTTD"
+HOMEPAGE="http://www.openttd.org/en/download-catcodec"
+SRC_URI="http://binaries.openttd.org/extra/catcodec/${PV}/${P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dobin catcodec || die
+ dodoc README || die
+ doman catcodec.1 || die
+}
diff --git a/games-util/catcodec/files/catcodec-1.0.0-build.patch b/games-util/catcodec/files/catcodec-1.0.0-build.patch
new file mode 100644
index 000000000000..ebc5f7cda440
--- /dev/null
+++ b/games-util/catcodec/files/catcodec-1.0.0-build.patch
@@ -0,0 +1,26 @@
+diff -ru catcodec-1.0.0.orig/Makefile catcodec-1.0.0/Makefile
+--- catcodec-1.0.0.orig/Makefile 2009-11-05 17:33:48.000000000 -0500
++++ catcodec-1.0.0/Makefile 2010-04-07 12:52:09.839777068 -0400
+@@ -19,18 +19,18 @@
+ OBJS = catcodec.o io.o sample.o rev.o
+ OS = unknown
+
+-CFLAGS += -Wall -Wcast-qual -Wwrite-strings -Wno-multichar
++CXXFLAGS += -Wall -Wcast-qual -Wwrite-strings -Wno-multichar
+ ifdef DEBUG
+- CFLAGS += -g -ggdb
++ CXXFLAGS += -g -ggdb
+ endif
+
+ all: $(CATCODEC)
+
+ %.o: %.cpp
+- $(CXX) $(CFLAGS) -c -o $@ $^
++ $(CXX) $(CXXFLAGS) -c -o $@ $^
+
+ $(CATCODEC): $(OBJS)
+- $(CXX) $(CFLAGS) -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+ VERSION := $(shell ./findversion.sh | cut -f 1 -d' ')
+ RES := $(shell if [ "`cat version.cache 2>/dev/null`" != "$(VERSION)" ]; then echo "$(VERSION)" > version.cache; fi )
diff --git a/games-util/catcodec/metadata.xml b/games-util/catcodec/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/catcodec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>