summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2 (patch)
treee60f463f55aa5aac16ff1a139d0cbf4a2e4d9128 /gnome-extra/libgda
parent- bah. forgot digest. (diff)
downloadhistorical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.gz
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.bz2
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.zip
*** empty log message ***
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.91
-rw-r--r--gnome-extra/libgda/libgda-0.2.9.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.9 b/gnome-extra/libgda/files/digest-libgda-0.2.9
new file mode 100644
index 000000000000..5f45483be561
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.9
@@ -0,0 +1 @@
+MD5 572b2b19a2e959aaa150ab490c57fb76 libgda-0.2.9.tar.gz
diff --git a/gnome-extra/libgda/libgda-0.2.9.ebuild b/gnome-extra/libgda/libgda-0.2.9.ebuild
new file mode 100644
index 000000000000..b6ce9e4a5664
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND="virtual/glibc sys-apps/which
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=gnome-base/gconf-0.11
+ >=dev-perl/CORBA-ORBit-0.4.3
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-0.11
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+src_compile() {
+ local myconf
+ if [ "`use mysql`" ] ; then
+ myconf="--with-mysql=/usr"
+ fi
+ if [ "`use ldap`" ] ; then
+ myconf="$myconf --with-ldap=/usr"
+ fi
+ if [ "`use odbc`" ]; then
+ myconf="$myconf --with-odbc"
+ fi
+ if [ "`use postgres`" ]; then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
+ try make LDFLAGS=\"-lncurses\" LIBREADLINE=\"-lreadline -lncurses\"
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=/etc/opt/gnome \
+ PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install
+ into /usr
+ dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+
+
+