summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2010-09-14 22:37:56 +0000
committerRobert Piasek <dagger@gentoo.org>2010-09-14 22:37:56 +0000
commit63330c67041a199b0bbec2d75df74a9801328b38 (patch)
tree947031429f972d156682ca0654be4460303ef67d /gnome-extra/nm-applet/files
parentwhitespace (diff)
downloadhistorical-63330c67041a199b0bbec2d75df74a9801328b38.tar.gz
historical-63330c67041a199b0bbec2d75df74a9801328b38.tar.bz2
historical-63330c67041a199b0bbec2d75df74a9801328b38.zip
Backported patch which fixes bluetooth dependency automagic
Package-Manager: portage-2.1.9.5/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/nm-applet/files')
-rw-r--r--gnome-extra/nm-applet/files/nm-applet-0.8.1-fix-bluetooth-dep.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/files/nm-applet-0.8.1-fix-bluetooth-dep.patch b/gnome-extra/nm-applet/files/nm-applet-0.8.1-fix-bluetooth-dep.patch
new file mode 100644
index 000000000000..ead490fc0c22
--- /dev/null
+++ b/gnome-extra/nm-applet/files/nm-applet-0.8.1-fix-bluetooth-dep.patch
@@ -0,0 +1,43 @@
+From e523771e0d68c347763a004a3f9ac100db5cfbb2 Mon Sep 17 00:00:00 2001
+From: Dan Williams <dcbw@redhat.com>
+Date: Tue, 24 Aug 2010 16:05:01 +0000
+Subject: build: allow explicit enabling/disabling of gnome-bluetooth dep (bgo #627663)
+
+---
+diff --git a/configure.ac b/configure.ac
+index 1ab81f4..b2dd2cd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -97,12 +97,24 @@ fi
+ AC_SUBST(DBUS_SYS_DIR)
+
+ dnl Check for gnome-bluetooth
+-PKG_CHECK_MODULES(GNOME_BLUETOOTH,
+- gconf-2.0
+- gnome-bluetooth-1.0 >= 2.27.6
+- libnm-util >= 0.8.1
+- libnm-glib >= 0.8.1,
+- have_gbt=yes, have_gbt=no)
++AC_ARG_WITH([bluetooth],
++ AS_HELP_STRING([--with-bluetooth|--without-bluetooth], [Enable Bluetooth support]),
++ with_bluetooth="$withval",with_bluetooth=yes)
++have_gbt=no
++case "${with_bluetooth}" in
++ no) AC_MSG_NOTICE(Bluetooth support disabled)
++ ;;
++ *)
++ AC_MSG_CHECKING(for gnome-bluetooth)
++ PKG_CHECK_MODULES(GNOME_BLUETOOTH,
++ gconf-2.0
++ gnome-bluetooth-1.0 >= 2.27.6
++ libnm-util >= 0.8.1
++ libnm-glib >= 0.8.1,
++ have_gbt=yes, have_gbt=no)
++ ;;
++esac
++
+ AM_CONDITIONAL(HAVE_GBT, test x"$have_gbt" = "xyes")
+
+ AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
+--
+cgit v0.8.3.1