summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commitb900c5b419baaf47bcd309ef6d8a932d630c79be (patch)
tree0ac77639648e73041ce5b313801ae2608e40ce15 /kde-base/kate
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadhistorical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.gz
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.bz2
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.zip
Add KDE SC 4.5.2 =)
Package-Manager: portage-2.2_rc88_p115/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.5.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 3ae223fd220a..565785a5ac42 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.184 2010/09/05 23:24:33 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.185 2010/10/06 09:17:25 alexxy Exp $
+
+*kate-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
*kate-4.5.1 (05 Sep 2010)
diff --git a/kde-base/kate/kate-4.5.2.ebuild b/kde-base/kate/kate-4.5.2.ebuild
new file mode 100644
index 000000000000..13e1501a442c
--- /dev/null
+++ b/kde-base/kate/kate-4.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.5.2.ebuild,v 1.1 2010/10/06 09:17:25 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}