summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-05 19:14:09 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-05 19:14:09 +0000
commitb53e1901050a2a92901314e833b0ce0f2d4d58bf (patch)
tree40e0a8f75df55aea782a3d4a80210928c4d14af8 /kde-base/kdelibs
parentfor the upcoming kde 3.0.1.20020604 (diff)
downloadhistorical-b53e1901050a2a92901314e833b0ce0f2d4d58bf.tar.gz
historical-b53e1901050a2a92901314e833b0ce0f2d4d58bf.tar.bz2
historical-b53e1901050a2a92901314e833b0ce0f2d4d58bf.zip
kde 3.0.1.20020604 :-) explanation in the announcement that should be tomorrow, masked for now.
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.0.1.200206042
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.1.20020604.ebuild100
2 files changed, 102 insertions, 0 deletions
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.0.1.20020604 b/kde-base/kdelibs/files/digest-kdelibs-3.0.1.20020604
new file mode 100644
index 000000000000..77a9b1d56088
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.0.1.20020604
@@ -0,0 +1,2 @@
+MD5 b2e0e7e270516fd28fa808b13bfe2bb9 kdelibs-3.0.1-20020604.diff 56015
+MD5 3a9b75af1d8916194cae27935c1c59d5 kdelibs-3.0.1.tar.bz2 7593201
diff --git a/kde-base/kdelibs/kdelibs-3.0.1.20020604.ebuild b/kde-base/kdelibs/kdelibs-3.0.1.20020604.ebuild
new file mode 100644
index 000000000000..d56ae5ddc767
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.0.1.20020604.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.1.20020604.ebuild,v 1.1 2002/06/05 19:14:09 danarmak Exp $
+
+inherit kde-patch kde kde.org
+#don't inherit kde-patch kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE ${PV} - Libraries"
+HOMEPAGE="http//www.kde.org/"
+
+SLOT="3"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ >=kde-base/arts-1.0.1
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python"
+
+myconf="$myconf --enable-final --with-distribution=Gentoo"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+ if [ "$KDE3DIR" != "$KDE3LIBSDIR" ]; then
+echo "PATH=${KDE3LIBSDIR}/bin:${KDE3DIR}/bin
+ROOTPATH=${KDE3LIBSDIR}/bin:${KDE3DIR}/bin
+LDPATH=${KDE3LIBSDIR}/lib:${KDE3DIR}/lib" > ${D}/etc/env.d/65kdelibs-${PV}
+ else
+echo "PATH=${KDE3LIBSDIR}/bin
+ROOTPATH=${KDE3LIBSDIR}/bin
+LDPATH=${KDE3LIBSDIR}/lib" > ${D}/etc/env.d/65kdelibs-${PV}
+ fi
+
+ echo "KDEDIR=${KDE3DIR}" > ${D}/etc/env.d/50kdedir-${PV}
+
+ dodir /usr/qt/3
+ cd ${D}
+ mv ./${KDEDIR}/lib/kde3/plugins ./usr/qt/3
+ dosym /usr/qt/3/plugins /${KDEDIR}/lib/kde3/plugins
+
+}
+
+