summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kgpg
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kgpg')
-rw-r--r--kde-base/kgpg/ChangeLog7
-rw-r--r--kde-base/kgpg/kgpg-3.5.9.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/kde-base/kgpg/ChangeLog b/kde-base/kgpg/ChangeLog
index 59546bd78156..a109e0fe2862 100644
--- a/kde-base/kgpg/ChangeLog
+++ b/kde-base/kgpg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kgpg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/ChangeLog,v 1.81 2008/02/17 02:09:06 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/ChangeLog,v 1.82 2008/02/20 23:01:07 philantrop Exp $
+
+*kgpg-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kgpg-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kgpg-3.5.5.ebuild,
-kgpg-3.5.6.ebuild, -kgpg-3.5.7.ebuild, -kgpg-4.0.0.ebuild:
diff --git a/kde-base/kgpg/kgpg-3.5.9.ebuild b/kde-base/kgpg/kgpg-3.5.9.ebuild
new file mode 100644
index 000000000000..186c8e3d1bd3
--- /dev/null
+++ b/kde-base/kgpg/kgpg-3.5.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.9.ebuild,v 1.1 2008/02/20 23:01:07 philantrop Exp $
+
+KMNAME=kdeutils
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE gpg keyring manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility"
+
+RDEPEND="${RDEPEND}
+ app-crypt/gnupg
+ app-crypt/pinentry"
+
+pkg_setup() {
+ if ! built_with_use app-crypt/pinentry gtk && ! built_with_use app-crypt/pinentry qt3 ; then
+ eerror "${PN} needs app-crypt/pinentry built with either the gtk or qt3 USE flag."
+ eerror "Please enable either USE flag and re-install app-crypt/pinentry."
+ die "app-crypt/pinentry needs to be rebuilt with gtk or qt3 support."
+ fi
+
+ kde_pkg_setup
+}