summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
commitb974b6ef740bd72ca318243730adf05a46a3ac13 (patch)
tree83960462b16e9bb431666835e4b3d90f67f1c45c /kde-base/ksayit/ksayit-3.5.10.ebuild
parentVersion bump and include patch to support Audacious 1.5. (diff)
downloadhistorical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.gz
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.bz2
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.zip
Version bump.
Diffstat (limited to 'kde-base/ksayit/ksayit-3.5.10.ebuild')
-rw-r--r--kde-base/ksayit/ksayit-3.5.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-base/ksayit/ksayit-3.5.10.ebuild b/kde-base/ksayit/ksayit-3.5.10.ebuild
new file mode 100644
index 000000000000..785fcac3aeb0
--- /dev/null
+++ b/kde-base/ksayit/ksayit-3.5.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksayit/ksayit-3.5.10.ebuild,v 1.1 2008/09/13 23:59:39 carlo Exp $
+KMNAME=kdeaccessibility
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="KDE text-to-speech frontend."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=kde-base/kttsd-${PV}:${SLOT}
+ || ( >=kde-base/kdemultimedia-arts-${PV}:${SLOT} >=kde-base/kdemultimedia-${PV}:${SLOT} )"
+
+pkg_setup() {
+ kde_pkg_setup
+
+ if has_version kde-base/kdemultimedia:${SLOT} && ! built_with_use kde-base/kdemultimedia:${SLOT} arts ; then
+ eerror "You have \"arts\" USE flag enabled, but kde-base/kdemultimedia:${SLOT} was built with this flag disabled."
+ die "Reinstall kde-base/kdemultimedia:${SLOT} with USE=\"arts\""
+ fi
+}
+
+src_compile() {
+ myconf="--enable-ksayit-audio-plugins"
+ kde-meta_src_compile
+}