summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 19:53:57 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 19:53:57 +0000
commit738043827276876bc69a3a67884d29dc745d32a7 (patch)
tree45bb44ba64e7411df0baa913b316753aa3037e21 /kde-base/phonon-kde
parentFix ebuild.badheader (diff)
downloadhistorical-738043827276876bc69a3a67884d29dc745d32a7.tar.gz
historical-738043827276876bc69a3a67884d29dc745d32a7.tar.bz2
historical-738043827276876bc69a3a67884d29dc745d32a7.zip
Version bump KDE 4.4.1
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.4.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 1e3630b5f3db..f5d531ebcba0 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.47 2010/02/20 12:05:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.48 2010/03/02 19:36:55 tampakrap Exp $
+
+*phonon-kde-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +phonon-kde-4.4.1.ebuild:
+ Version bump
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
phonon-kde-4.3.5.ebuild:
diff --git a/kde-base/phonon-kde/phonon-kde-4.4.1.ebuild b/kde-base/phonon-kde/phonon-kde-4.4.1.ebuild
new file mode 100644
index 000000000000..b6342f028b4d
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.4.1.ebuild,v 1.1 2010/03/02 19:36:55 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug +xine"
+
+DEPEND="
+ >=media-sound/phonon-4.3.80[xine?]
+ alsa? ( media-libs/alsa-lib )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.4-optional-alsa.patch
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with xine)
+ )
+
+ kde4-meta_src_configure
+}