summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commit6010bfdb4951b252d0178466152533f87a47a205 (patch)
treec46457b1233e7a5503540b92a2ef5d8cbfd9b4dc /kde-base/superkaramba
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadhistorical-6010bfdb4951b252d0178466152533f87a47a205.tar.gz
historical-6010bfdb4951b252d0178466152533f87a47a205.tar.bz2
historical-6010bfdb4951b252d0178466152533f87a47a205.zip
Version bump KDE SC 4.11.2
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x42618354
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.11.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 608b8f428a7a..ac291b64bc62 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.267 2013/09/05 18:44:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.268 2013/10/09 23:04:21 creffett Exp $
+
+*superkaramba-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +superkaramba-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
05 Sep 2013; Michał Górny <mgorny@gentoo.org> superkaramba-4.10.5.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/kde-base/superkaramba/superkaramba-4.11.2.ebuild b/kde-base/superkaramba/superkaramba-4.11.2.ebuild
new file mode 100644
index 000000000000..a2fda0fdbfca
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.11.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.11.2.ebuild,v 1.1 2013/10/09 23:04:22 creffett Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+HOMEPAGE="http://www.kde.org/applications/utilities/superkaramba
+http://utils.kde.org/projects/superkaramba"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ media-libs/qimageblitz
+ x11-libs/libX11
+ x11-libs/libXrender
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+ )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython "${PYTHON_USEDEP}") )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}