summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-06-12 12:27:14 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-06-12 12:27:14 +0000
commitaac76602b5eb56e4bb3116d5ad1135b4188ff2da (patch)
tree7acba676eff3379384eae35443e47cf807351032 /kde-base
parentsyntax fix (diff)
downloadhistorical-aac76602b5eb56e4bb3116d5ad1135b4188ff2da.tar.gz
historical-aac76602b5eb56e4bb3116d5ad1135b4188ff2da.tar.bz2
historical-aac76602b5eb56e4bb3116d5ad1135b4188ff2da.zip
gcc34 patch readd
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeaddons/Manifest3
-rw-r--r--kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch28
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.2.3.ebuild4
3 files changed, 32 insertions, 3 deletions
diff --git a/kde-base/kdeaddons/Manifest b/kde-base/kdeaddons/Manifest
index d426d65cc04c..798ce17b0cd0 100644
--- a/kde-base/kdeaddons/Manifest
+++ b/kde-base/kdeaddons/Manifest
@@ -5,7 +5,7 @@ MD5 652bd5025f24b3af7b82b7c6a288a4ee ChangeLog 11683
MD5 cc4c2aa722bd21cc306b1be8da3f94f6 kdeaddons-3.3.0_alpha1.ebuild 950
MD5 4ddee4557fea410aa33ddae39b801b4f kdeaddons-3.1.5.ebuild 1423
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
-MD5 bf5542a53229455138ce1e744169e3e2 kdeaddons-3.2.3.ebuild 959
+MD5 35a7362d9f76a896f37d5a49cb9f7efa kdeaddons-3.2.3.ebuild 993
MD5 ee9fff88c4c48e7e34d37f8bb495db0d files/kdeaddons-3.1.5-enable-crashes.diff 1415
MD5 3bec1549e74c6f661045a83198e45290 files/kdeaddons-3.2.0-kvim.diff 363
MD5 913bd9f1c52d68ec7faa72960464132e files/kdeaddons-3.2.2-gcc34.patch 1256
@@ -14,4 +14,5 @@ MD5 22eee0845b6b7a62a9289a761f7632c1 files/digest-kdeaddons-3.2.0 69
MD5 87f8a1a1f19063274caebeba888cb372 files/digest-kdeaddons-3.2.1 69
MD5 de8403f5c3e2d4b96c14da3533d5aeb4 files/digest-kdeaddons-3.2.2 69
MD5 e773fdc5e9bf3ab47e4dada5fba0ebbe files/digest-kdeaddons-3.2.3 69
+MD5 913bd9f1c52d68ec7faa72960464132e files/kdeaddons-3.2.3-gcc34.patch 1256
MD5 ee2790d9984e61ebfd7bf612303a2365 files/digest-kdeaddons-3.3.0_alpha1 70
diff --git a/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch b/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch
new file mode 100644
index 000000000000..75ab7123e372
--- /dev/null
+++ b/kde-base/kdeaddons/files/kdeaddons-3.2.3-gcc34.patch
@@ -0,0 +1,28 @@
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/synaescope/polygon.h
+--- noatun-plugins/synaescope/polygon.h 2001-04-17 03:20:34.000000000 +0400
++++ noatun-plugins/synaescope/polygon.h 2004-04-24 09:51:48.355249296 +0400
+@@ -25,6 +25,10 @@
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel>
+ {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
+diff -udBbr kdeaddons-3.2.2/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h kdeaddons-3.2.2-fix1/work/kdeaddons-3.2.2/noatun-plugins/tippercanoe/polygon.h
+--- noatun-plugins/tippercanoe/polygon.h 2001-04-17 02:04:03.000000000 +0400
++++ noatun-plugins/tippercanoe/polygon.h 2004-04-24 09:58:30.243153048 +0400
+@@ -23,6 +23,10 @@
+
+ template<class Pixel, class Combiner, int superSampleShift>
+ struct PolygonEngine : public Bitmap<Pixel> {
++ using Bitmap<Pixel>::width;
++ using Bitmap<Pixel>::height;
++ using Bitmap<Pixel>::data;
++
+ PolygonEngine() : Bitmap<Pixel>(1) { }
+
+ #define super (1<<superSampleShift)
diff --git a/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild b/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
index 8b7e44f41bb3..5e2a35a9d4f4 100644
--- a/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
+++ b/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild,v 1.1 2004/06/10 22:45:24 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.2.3.ebuild,v 1.2 2004/06/12 12:27:14 caleb Exp $
inherit kde-dist flag-o-matic
@@ -24,4 +24,4 @@ use xmms || export ac_cv_have_xmms=no
# Make vimpart use /usr/bin/kvim -- fixes bug 33257.
# This should continue to apply to upcoming versions since it's
# Gentoo-specific and won't go upstream.
-PATCHES="$FILESDIR/${PN}-3.2.0-kvim.diff"
+PATCHES="$FILESDIR/${PN}-3.2.0-kvim.diff $FILESDIR/${PN}-3.2.3-gcc34.patch"