summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-10 22:49:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-10 22:49:48 +0000
commitca5bc1542f4491d91cfc7efd544a23812dfc2663 (patch)
tree48762b926a46fb989cdb926fe9c79d07cb6799be /mail-client
parentUse bashrc hook function instead of EBUILD_PHASE; check ROOT (#327563 by ferr... (diff)
downloadhistorical-ca5bc1542f4491d91cfc7efd544a23812dfc2663.tar.gz
historical-ca5bc1542f4491d91cfc7efd544a23812dfc2663.tar.bz2
historical-ca5bc1542f4491d91cfc7efd544a23812dfc2663.zip
Respect CC/CFLAGS/LDFLAGS wrt bug #244134 and bug #240778
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/pine/ChangeLog7
-rw-r--r--mail-client/pine/Manifest3
-rw-r--r--mail-client/pine/pine-4.64-r8.ebuild194
3 files changed, 202 insertions, 2 deletions
diff --git a/mail-client/pine/ChangeLog b/mail-client/pine/ChangeLog
index 6d20928bfcde..bbb878ea9543 100644
--- a/mail-client/pine/ChangeLog
+++ b/mail-client/pine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/pine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.109 2010/06/25 17:45:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.110 2010/07/10 22:49:48 hwoarang Exp $
+
+*pine-4.64-r8 (10 Jul 2010)
+
+ 10 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +pine-4.64-r8.ebuild:
+ Respect CC/CFLAGS/LDFLAGS wrt bug #244134 and bug #240778
25 Jun 2010; Raúl Porcel <armin76@gentoo.org> pine-4.64-r6.ebuild,
pine-4.64-r7.ebuild:
diff --git a/mail-client/pine/Manifest b/mail-client/pine/Manifest
index c1531756c96b..63183b5abee7 100644
--- a/mail-client/pine/Manifest
+++ b/mail-client/pine/Manifest
@@ -17,5 +17,6 @@ DIST pine4.64.tar.bz2 3110790 RMD160 8661cd3c0875e46c8cd5eafa7c7c964f79a3b3fd SH
EBUILD pine-4.64-r5.ebuild 5535 RMD160 1838c09c5244239ce1f8389fdbcd9e8f38e9bbff SHA1 c8a8b4292bc859cec23946a12fbd3c636aa7dd54 SHA256 354f623d5c01ef61fcb625f029d47a4bf391bb5d396c04be03ce6ab329a30663
EBUILD pine-4.64-r6.ebuild 5913 RMD160 b9babc98f8c7e4aac7c1e267f3d048a733f445dd SHA1 effb2065cede4a740a7047faaed94282a75448ad SHA256 3ce7a15845c24ad78f16dd7170dfc401ac1051e150bfc6d53c375064c4e888b4
EBUILD pine-4.64-r7.ebuild 6074 RMD160 d170f75324d37d164ce3e576d19a987814a2ec94 SHA1 547f0f43f335fafe500ac6f46642943a4e9ba96c SHA256 59c0b5d848cfd4e7d66811164272840ea3ff63161e22d82d9e04887e7366e668
-MISC ChangeLog 23730 RMD160 3890b71d531d872f69728f7fea53812923ebee98 SHA1 5dd53c97dff8ba8033f2f0e18c94d332a5201c65 SHA256 89e3705ea3fde1b1182c962bde83ba02143b5d2d199c3ff1aaa9d707dcf56701
+EBUILD pine-4.64-r8.ebuild 6174 RMD160 5b3352ff8f68ce8a6992836081d5aac80607b713 SHA1 bc706874129d92f9ce22d7d811c31f1ac6d8d906 SHA256 6d1b10fe12dc97c937fbd1987be49acff67c4ca8a8fd12d15d6ccabcdedb3a9e
+MISC ChangeLog 23896 RMD160 56abdee052bae5f3483346e9370079e4d482beaa SHA1 5f1a6913a6c799e42f144bb760735acf2866048b SHA256 b250672dcb78aaac9a0c22e80d5055fbe11cfd963b3d3f12815ad065c326c55d
MISC metadata.xml 399 RMD160 d040cc64dc9e8a124319a1aabfb5da6ad56baaf8 SHA1 2002632d6f4236f1db97e695d5e046dda10d832f SHA256 974021bbe96256ccf1286bcda1ca194e67f8fc0a7ce0b968007d993fd09cf08a
diff --git a/mail-client/pine/pine-4.64-r8.ebuild b/mail-client/pine/pine-4.64-r8.ebuild
new file mode 100644
index 000000000000..1552645ec839
--- /dev/null
+++ b/mail-client/pine/pine-4.64-r8.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64-r8.ebuild,v 1.1 2010/07/10 22:49:48 hwoarang Exp $
+
+EAPI=3
+inherit eutils
+
+# Using this ugly hack, since we're making our own versioned copies of chappa
+# patch, as upstream doesn't version them, and patch revision number doesn't
+# always have to correspond to ebuild revision number. (see #59573)
+CHAPPA_PF="${P}-r7"
+
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+HOMEPAGE="http://www.washington.edu/pine/
+ http://staff.washington.edu/chappa/pine/"
+SRC_URI="ftp://ftp.cac.washington.edu/pine/${P/-/}.tar.bz2
+ mirror://gentoo/${CHAPPA_PF}-chappa-all.patch.gz"
+# ipv6? (
+# http://www.ngn.euro6ix.org/IPv6/${PN}/${P}-v6-20031001.diff
+# http://www.ngn.euro6ix.org/IPv6/${PN}/readme.${P}-v6-20031001
+# )"
+
+LICENSE="PICO"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ssl ldap kerberos largeterminal pam passfile debug"
+
+DEPEND=">=sys-apps/sed-4
+ >=sys-libs/ncurses-5.1
+ pam? ( virtual/pam )
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ net-mail/uw-mailutils
+ !<=net-mail/uw-imap-2004g"
+
+S="${WORKDIR}/${P/-/}"
+
+maildir_warn() {
+ einfo
+ einfo "This build of Pine has Maildir support built in as"
+ einfo "part of the chappa-all patch."
+ einfo
+ einfo "If you have a maildir at ~/Maildir it will be your"
+ einfo "default INBOX. The path may be changed with the"
+ einfo "\"maildir-location\" setting in Pine."
+ einfo
+ einfo "To use /var/spool/mail INBOX again, set"
+ einfo "\"disable-these-drivers=md\" in your .pinerc file."
+ einfo
+ einfo "Alternately, you might want to read following webpage, which explains how to"
+ einfo "use multiple mailboxes simultaneously:"
+ echo
+ echo "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+ echo
+}
+
+pkg_setup() {
+ maildir_warn
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/pine-4.62-spooldir-permissions.patch"
+
+ # Various fixes and features.
+ epatch "${WORKDIR}/${CHAPPA_PF}-chappa-all.patch"
+ # Fix flock() emulation.
+ cp "${FILESDIR}/flock.c" "${S}/imap/src/osdep/unix" || die
+ # Build the flock() emulation.
+ epatch "${FILESDIR}/imap-4.7c2-flock_4.60.patch"
+ if use ldap ; then
+ # Link to shared ldap libs instead of static.
+ epatch "${FILESDIR}/pine-4.30-ldap.patch"
+ mkdir "${S}/ldap"
+ ln -s /usr/lib "${S}/ldap/libraries"
+ ln -s /usr/include "${S}/ldap/include"
+ fi
+# if use ipv6 ; then
+# epatch "${DISTDIR}/${P}-v6-20031001.diff" || die
+# fi
+ if use passfile ; then
+ #Is this really the correct place to define it?
+ epatch "${FILESDIR}/pine-4.56-passfile.patch"
+ fi
+ if use largeterminal ; then
+ # Add support for large terminals by doubling the size of pine's internal display buffer
+ epatch "${FILESDIR}/pine-4.61-largeterminal.patch"
+ fi
+
+ # Something from RedHat.
+ epatch "${FILESDIR}/pine-4.31-segfix.patch"
+ # Create lockfiles with a mode of 0600 instead of 0666.
+ epatch "${FILESDIR}/pine-4.40-lockfile-perm.patch"
+ # Add missing time.h includes.
+ epatch "${FILESDIR}/imap-2000-time.patch"
+ # Bug #23336 - makes pine transparent in terms that support it.
+ epatch "${FILESDIR}/transparency.patch"
+ # Bug #72861 - relaxes subject length for base64-encoded subjects
+ epatch "${FILESDIR}/pine-4.61-subjectlength.patch"
+ # Bug #58664 - preserve symlink if a file gets rewritten
+ epatch "${FILESDIR}/${P}-rename-symlink.patch"
+
+ if use debug ; then
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ else
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ fi
+
+ sed -e "s:/usr/local/lib/pine.conf:${EPREFIX}/etc/pine.conf:" \
+ -i "${S}/pine/osdep/os-lnx.h" || die "sed os-lnx.h failed"
+
+ sed -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
+ -i "${S}/pine/osdep/os-bsf.h" || die "sed os-bsf.h failed"
+
+ # We use ncurses for FreeBSD
+ for x in "${S}"/*/makefile.bsf ; do
+ sed -e "s/-ltermcap/-lcurses/g" -e "s/-ltermlib/-lcurses/g" \
+ -i "${x}" || die "sed ${x} failed"
+ done
+}
+
+src_compile() {
+ local myconf
+ if use ssl ; then
+ myconf="${myconf} SSLDIR=${EPREFIX}/usr SSLTYPE=unix SSLCERTS=${EPREFIX}/etc/ssl/certs"
+ sed -e "s:\$(SSLDIR)/certs:${EPREFIX}/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):${EPREFIX}/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE):-I${EPREFIX}/usr/include/openssl:" \
+ -i "${S}/imap/src/osdep/unix/Makefile" || die "sed Makefile failed"
+ else
+ myconf="${myconf} NOSSL"
+ fi
+ if use ldap ; then
+ ./contrib/ldap-setup lnp lnp
+ myconf="${myconf} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ myconf="${myconf} NOLDAP"
+ fi
+ if use kerberos ; then
+ myconf="${myconf} EXTRAAUTHENTICATORS=gss"
+ fi
+
+ if use elibc_FreeBSD ; then
+ target=bsf
+ elif use pam ; then
+ [[ ${CHOST} == *-darwin* ]] && target=oxp || target=lnp
+ else
+ [[ ${CHOST} == *-darwin* ]] && target=osx || target=slx
+ fi
+ myconf="${myconf} CC=\"$(tc-getCC)\""
+ ./build ${myconf} ${target} EXTRACFLAGS="${CFLAGS}" \
+ EXTRALDFLAGS="${LDFLAGS}" || die "compile problem"
+}
+
+src_install() {
+ dobin bin/pine bin/pico bin/pilot bin/rpdump bin/rpload
+
+ # Only mailbase should install /etc/mailcap
+# newins doc/mailcap.unx mailcap
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+# if use ipv6 ; then
+# dodoc "${DISTDIR}/readme.${P}-v6-20031001"
+# fi
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+}
+
+pkg_postinst() {
+ maildir_warn
+
+ if use passfile ; then
+ elog
+ elog "Pine will cache passwords between connections."
+ elog "File ~/.pinepw will be used for this."
+ elog
+ fi
+}