summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-11-19 21:32:16 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-11-19 21:32:16 +0000
commit0155001eb477b8f1eea9bc8342dd473e110de042 (patch)
treee878b19db4b79a48be9749e593c76fdfaefe200e /mail-mta
parentVersion bump; updates binfmt_elf patch (bug #70681) and adds the smbfs securi... (diff)
downloadhistorical-0155001eb477b8f1eea9bc8342dd473e110de042.tar.gz
historical-0155001eb477b8f1eea9bc8342dd473e110de042.tar.bz2
historical-0155001eb477b8f1eea9bc8342dd473e110de042.zip
work in progress
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/courier-authlib/ChangeLog8
-rw-r--r--mail-mta/courier-authlib/Manifest4
-rw-r--r--mail-mta/courier-authlib/courier-authlib-0.50.20041116.ebuild77
-rw-r--r--mail-mta/courier-authlib/files/digest-courier-authlib-0.50.200411161
4 files changed, 88 insertions, 2 deletions
diff --git a/mail-mta/courier-authlib/ChangeLog b/mail-mta/courier-authlib/ChangeLog
index 9713be565656..bbdb2b56039d 100644
--- a/mail-mta/courier-authlib/ChangeLog
+++ b/mail-mta/courier-authlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/courier-authlib
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier-authlib/ChangeLog,v 1.2 2004/11/16 23:05:18 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier-authlib/ChangeLog,v 1.3 2004/11/19 21:32:16 swtaylor Exp $
+
+*courier-authlib-0.50.20041116 (19 Nov 2004)
+
+ 19 Nov 2004; Scott W Taylor <swtaylor@gentoo.org>
+ +courier-authlib-0.50.20041116.ebuild:
+ bump. still work in progress.
16 Nov 2004; Scott W Taylor <swtaylor@gentoo.org>
courier-authlib-0.50.20041113.ebuild:
diff --git a/mail-mta/courier-authlib/Manifest b/mail-mta/courier-authlib/Manifest
index f6a0f1904df4..ce54a1d59871 100644
--- a/mail-mta/courier-authlib/Manifest
+++ b/mail-mta/courier-authlib/Manifest
@@ -1,4 +1,6 @@
+MD5 a82bd1f77f821ce3b41422ed28327f4e courier-authlib-0.50.20041116.ebuild 2598
MD5 44ec2110954f4b5ffd12e672af4e3679 courier-authlib-0.50.20041113.ebuild 2598
-MD5 5a034035f62731aa87ba062cf4e0d832 ChangeLog 527
+MD5 48f995af13adaaa84967308c659ddfbd ChangeLog 699
MD5 1639b87658242c2406f7f7f8deda7388 metadata.xml 334
MD5 c52c07c376700ecd34570d344874c984 files/digest-courier-authlib-0.50.20041113 83
+MD5 ee0f85c1e7a26c660ce65b08a89fcfbb files/digest-courier-authlib-0.50.20041116 83
diff --git a/mail-mta/courier-authlib/courier-authlib-0.50.20041116.ebuild b/mail-mta/courier-authlib/courier-authlib-0.50.20041116.ebuild
new file mode 100644
index 000000000000..a1416a148463
--- /dev/null
+++ b/mail-mta/courier-authlib/courier-authlib-0.50.20041116.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier-authlib/courier-authlib-0.50.20041116.ebuild,v 1.1 2004/11/19 21:32:16 swtaylor Exp $
+
+inherit eutils
+
+DESCRIPTION="courier authentication library"
+[ -z "${PV/?.??/}" ] && SRC_URI="mirror://sourceforge/courier-authlib/${P}.tar.bz2" || SRC_URI="http://www.courier-mta.org/beta/courier-authlib/${P}.tar.bz2"
+HOMEPAGE="http://www.courier-mta.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+#KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
+KEYWORDS="-*"
+IUSE="postgres ldap mysql gdbm pam crypt uclibc debug"
+
+DEPEND="virtual/libc"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if ! has_version 'dev-tcltk/expect' ; then
+ einfo 'The dev-tcltk/expect package is not installed.'
+ fi
+ unpack ${A}
+ cd ${S}
+ sed -e"s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
+ use uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
+}
+
+src_compile() {
+ local myconf
+ myconf="`use_with pam authpam` `use_with ldap authldap`"
+ use gdbm && myconf="${myconf} --with-db=gdbm"
+
+ if [ -f /var/vpopmail/etc/lib_deps ]; then
+ myconf="${myconf} --with-authvchkpw --without-authmysql --without-authpgsql"
+ use mysql && ewarn "vpopmail found. authmysql will not be built."
+ use postgres && ewarn "vpopmail found. authpgsql will not be built."
+ else
+ myconf="${myconf} --without-authvchkpw `use_with mysql authmysql` `use_with postgres authpostgres`"
+ fi
+
+ use debug && myconf="${myconf} debug=true"
+
+ewarn "${myconf}"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/courier \
+ --libexecdir=/usr/lib/courier \
+ --datadir=/usr/share/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --localstatedir=/var/lib/courier \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --cache-file=${S}/configuring.cache \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+ emake || die "Compile problem"
+}
+
+src_install() {
+ dodir /etc/courier/authlib
+ dodir /var/lib/courier
+ emake install DESTDIR="${D}" || die "install"
+ emake install-migrate DESTDIR="${D}" || die "migrate"
+ emake install-configure DESTDIR="${D}" || die "configure"
+ rm ${D}/etc/courier/authlib/*.bak
+ dodoc AUTHORS COPYING ChangeLog* INSTALL NEWS README
+ dohtml README.html README_authlib.html NEWS.html INSTALL.html README.authdebug.html
+ use ldap && dodoc authldap.schema
+ use mysql && ( dodoc README.authmysql.myownquery ; dohtml README.authmysql.html )
+ use postgres && dohtml README.authpostgres.html
+}
+
diff --git a/mail-mta/courier-authlib/files/digest-courier-authlib-0.50.20041116 b/mail-mta/courier-authlib/files/digest-courier-authlib-0.50.20041116
new file mode 100644
index 000000000000..5cd974166f26
--- /dev/null
+++ b/mail-mta/courier-authlib/files/digest-courier-authlib-0.50.20041116
@@ -0,0 +1 @@
+MD5 d6afed924f2195f55e17082336d679a7 courier-authlib-0.50.20041116.tar.bz2 1969809