summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-27 19:46:03 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-27 19:46:03 +0000
commit181a76888dc22e5c280e240c4896563d6e417551 (patch)
treeda700f4c7e87e71186517bc26b84f437ef6090fa /media-gfx/showimg
parentupdate (diff)
downloadhistorical-181a76888dc22e5c280e240c4896563d6e417551.tar.gz
historical-181a76888dc22e5c280e240c4896563d6e417551.tar.bz2
historical-181a76888dc22e5c280e240c4896563d6e417551.zip
New revision that adds a gcc3 patch and the missing kdebase dep. This fixes bug #4094.
Diffstat (limited to 'media-gfx/showimg')
-rw-r--r--media-gfx/showimg/ChangeLog11
-rw-r--r--media-gfx/showimg/files/digest-showimg-0.7-r11
-rw-r--r--media-gfx/showimg/files/showimg-0.7-gcc3.diff55
-rw-r--r--media-gfx/showimg/showimg-0.7-r1.ebuild17
4 files changed, 82 insertions, 2 deletions
diff --git a/media-gfx/showimg/ChangeLog b/media-gfx/showimg/ChangeLog
index 5fd5e142ac56..759d97177e7b 100644
--- a/media-gfx/showimg/ChangeLog
+++ b/media-gfx/showimg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/showimg
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/showimg/ChangeLog,v 1.1 2002/07/18 22:57:53 drobbins Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/showimg/ChangeLog,v 1.2 2002/07/27 19:46:03 danarmak Exp $
+
+*showimg-0.7-r1 (27 Jul 2002)
+
+ 27 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New revision that adds a gcc3 fix and a missing dep on kdebase, thus fixing
+ bug #4094.
*showimg-0.7 (18 Jul 2002)
diff --git a/media-gfx/showimg/files/digest-showimg-0.7-r1 b/media-gfx/showimg/files/digest-showimg-0.7-r1
new file mode 100644
index 000000000000..bc68b3ddfa1f
--- /dev/null
+++ b/media-gfx/showimg/files/digest-showimg-0.7-r1
@@ -0,0 +1 @@
+MD5 63d21ffe645975c9fb3d829955ec46c2 showimg-0.7.tar.bz2 748958
diff --git a/media-gfx/showimg/files/showimg-0.7-gcc3.diff b/media-gfx/showimg/files/showimg-0.7-gcc3.diff
new file mode 100644
index 000000000000..ce8e01499dc8
--- /dev/null
+++ b/media-gfx/showimg/files/showimg-0.7-gcc3.diff
@@ -0,0 +1,55 @@
+diff -ur showimg/batchrenamer.cpp showimg/batchrenamer.cpp
+--- showimg/batchrenamer.cpp Mon Dec 24 12:28:31 2001
++++ showimg/batchrenamer.cpp Sun Jul 28 11:08:55 2002
+@@ -29,7 +29,7 @@
+ {
+ }
+
+-void BatchRenamer::processFiles( struct data* files, enum mode m, struct values* val, bool preview = false )
++void BatchRenamer::processFiles( struct data* files, enum mode m, struct values* val, bool preview )
+ {
+ QString tmp;
+ int i;
+diff -ur showimg/history_action.cpp showimg/history_action.cpp
+--- showimg/history_action.cpp Mon Dec 24 12:28:31 2001
++++ showimg/history_action.cpp Sun Jul 28 11:06:47 2002
+@@ -7,7 +7,7 @@
+ #include <kiconloader.h>
+
+ HistoryAction::HistoryAction( const QString& text, const QString& icon, int accel,
+- const QObject* receiver, const char* slot, QObject* parent, const char* name = 0 )
++ const QObject* receiver, const char* slot, QObject* parent, const char* name )
+ : KAction( text, icon, accel, receiver, slot, parent, name )
+ {
+ m_popup = 0;
+diff -ur showimg/numSlider.cpp showimg/numSlider.cpp
+--- showimg/numSlider.cpp Mon Dec 24 12:28:31 2001
++++ showimg/numSlider.cpp Sun Jul 28 11:04:17 2002
+@@ -13,15 +13,15 @@
+
+ extern int max(int a, int b);
+
+-numSlider::numSlider( QWidget *parent=0, const char *name=0 )
++numSlider::numSlider( QWidget *parent, const char *name )
+ : QWidget(parent, name)
+ {
+ init(0, 10, 0, 0, QBoxLayout::LeftToRight);
+ }
+
+
+-numSlider::numSlider( QBoxLayout::Direction aDir, QWidget *parent=0,
+- const char *name=0 )
++numSlider::numSlider( QBoxLayout::Direction aDir, QWidget *parent,
++ const char *name )
+ : QWidget(parent, name)
+ {
+ init(0, 10, 0, 0, aDir);
+@@ -30,7 +30,7 @@
+
+ numSlider::numSlider(double minValue, double maxValue, int decimals,
+ double value, QBoxLayout::Direction aDir,
+- QWidget *parent=0, const char *name=0 )
++ QWidget *parent, const char *name )
+ : QWidget(parent, name)
+ {
+ init(minValue, maxValue, decimals, value, aDir);
diff --git a/media-gfx/showimg/showimg-0.7-r1.ebuild b/media-gfx/showimg/showimg-0.7-r1.ebuild
new file mode 100644
index 000000000000..982ec55e5bfc
--- /dev/null
+++ b/media-gfx/showimg/showimg-0.7-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/showimg/showimg-0.7-r1.ebuild,v 1.1 2002/07/27 19:46:03 danarmak Exp $
+inherit kde-base
+
+need-kde 2.2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ShowImg is a feature-rich image viewer for KDE"
+SRC_URI="http://www.jalix.org/projects/showimg/download/${PVR}/${P}.tar.bz2"
+HOMEPAGE="http://www.jalix.org/projects/showimg/"
+newdepend "=kde-base/kdebase-2.2*"
+
+PATCHES="${FILESDIR}/${P}-gcc3.diff"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"