summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-04 12:40:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-04 12:40:30 +0000
commit62c7739aaa2c141316072b00b8767836de71dce1 (patch)
treea77879cec6209cc1b41314a5bce250a7d8f61eb2 /media-gfx/xloadimage/files
parentAdd hungarian template pack, bug #272159 (diff)
downloadhistorical-62c7739aaa2c141316072b00b8767836de71dce1.tar.gz
historical-62c7739aaa2c141316072b00b8767836de71dce1.tar.bz2
historical-62c7739aaa2c141316072b00b8767836de71dce1.zip
Include stdlib.h for exit(3) and respect LDFLAGS when building uufilter binary.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/xloadimage/files')
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
new file mode 100644
index 000000000000..afdea768aa47
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
@@ -0,0 +1,23 @@
+diff -ur xloadimage.4.1.orig/Makefile.in xloadimage.4.1/Makefile.in
+--- xloadimage.4.1.orig/Makefile.in 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/Makefile.in 2009-09-04 15:38:50.000000000 +0300
+@@ -27,7 +27,7 @@
+ $(CC) -o $@ $(OBJS) build.o $(LDFLAGS) $(XLIB) $(LIBS)
+
+ uufilter: uufilter.c
+- $(CC) $(CFLAGS) $(DEFS) uufilter.c -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) uufilter.c -o $@
+
+ .c.o: config.h image.h
+ $(CC) $(CFLAGS) -c $(DEFS) $<
+diff -ur xloadimage.4.1.orig/uufilter.c xloadimage.4.1/uufilter.c
+--- xloadimage.4.1.orig/uufilter.c 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/uufilter.c 2009-09-04 15:37:59.000000000 +0300
+@@ -11,6 +11,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ int main(argc, argv)