summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
commit3d8cec75b1fc83a877e447524209f6dfb7180599 (patch)
treec937d4374de9d6541d99f20e41e07dd8dac85a8b /media-libs/libogg
parent*** empty log message *** (diff)
downloadhistorical-3d8cec75b1fc83a877e447524209f6dfb7180599.tar.gz
historical-3d8cec75b1fc83a877e447524209f6dfb7180599.tar.bz2
historical-3d8cec75b1fc83a877e447524209f6dfb7180599.zip
Maintainence and FHS 2.1 fixes
Added a lot of USE flags GGI support and lcms support for libmng
Diffstat (limited to 'media-libs/libogg')
-rw-r--r--media-libs/libogg/libogg-1.0_beta3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libogg/libogg-1.0_beta3-r1.ebuild b/media-libs/libogg/libogg-1.0_beta3-r1.ebuild
new file mode 100644
index 000000000000..a955173de8bc
--- /dev/null
+++ b/media-libs/libogg/libogg-1.0_beta3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pbg1854@garnet.acns.fsu.edu>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.0_beta3-r1.ebuild,v 1.1 2001/02/13 14:29:41 achim Exp $
+
+A=libogg-1.0beta3.tar.gz
+S=${WORKDIR}/libogg-1.0beta3
+DESCRIPTION="the Ogg media file format library"
+SRC_URI="http://www.vorbis.com/files/beta3/${A}"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ # remove the docs installed by make install, since I'll install
+ # them in portage package doc directory
+ echo "Removing docs installed by make install"
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS CHANGES COPYING README
+ docinto html
+ dodoc doc/*.{html,png}
+}